1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

R6300v2 Advanced Tomato VLAN Tagging

Discussion in 'Networking Issues' started by DaAwesomeP, Jan 26, 2017.

  1. DaAwesomeP

    DaAwesomeP Network Newbie Member

    I'm trying to set up a guest network with VLAN tagging between two R6300v2's with the latest Advanced Tomato. The main router has wireless disabled. I've had it all working for a while not with only 1 VLAN and no tagging, but now I want to properly set up a guest network shared between multiple APs.

    Main router (AP connected on port 2):
    • br0 (main network) 192.168.0.1, DHCP Enabled, 192.168.0.200-254 (I reserve 2-199 for reserved devices)
    • br1 (guest network) 192.168.1.1, DHCP Enabled, 192.168.1.200-254
    • VLAN 1: Port 1 no tagging, port 2 with tagging, port 3 no tagging, port 4 no tagging
    • VLAN 2 WAN port no tagging
    • VLAN 3: Port 2 with tagging
    AP (I tried using WAN, but after a restart the router would reset the VLAN bridging/mapping on the WAN port or override the bridge with tagging somewhere, so I'm using port 1):
    • br0 (main network) 192.168.0.102, DHCP Disabled
    • br1 (guest network) 192.168.1.102, DHCP Disabled
    • VLAN 1: Port 1 with tagging, port 2 no tagging, port 3 no tagging, port 4 no tagging
    • VLAN 2: WAN no tagging (disconnected anyway)
    • VLAN 3: Port 1 with tagging
    • The main WiFi is assigned to br0. I plan to assign the guest virtual WiFi to br1.
    This setup simply doesn't work, and I don't know why. I've had to reset the AP several times in my attempts to get this to work, as it is usually inaccessible after applying these settings. There is a direct CAT6 line between them (no switches).

    I think that there is some unconfigurable interference in my configuration. Even with the setting unchecked in the main network config, the WAN would still bridge to br0 without anything checked in VLAN options. If I tried to assign the WAN port to br0 and b1, after a restart it would have reset to only being assigned to VLAN 2 (WAN) with no tagging. However, when I tried to use port 1, the router would restart and become inaccessible both via WiFi (br0) and Ethernet. I'd prefer to use the WAN port, as the AP doubles as a switch.

    What is going wrong?
     
  2. DaAwesomeP

    DaAwesomeP Network Newbie Member

    OK, so I tried it again. Basically, after every reboot, the AP will reset VLAN1 and VLAN2 to the default. So ports 1-4 on br0 on VLAN1 and WAN on VLAN2. Oddly, the main router (same model) does not have this issue. The VLAN commit checkbox in the debugging section is unchecked on the AP and router.

    I tried another config with the following:
    • VLAN 1 br0: Port 1 no tagging, port 2 no tagging, WAN with tagging
    • VLAN 2 WAN: Port 4 no tagging (disconnected anyway)
    • VLAN 3 br1: Port 3 no tagging, WAN with tagging
    And this is what it resets to after reboot:
    [​IMG]
    You can see that it resets VLAN1 and VLAN and leaves VLAN3 as it should be. VLAN3 is operating correctly: I can access the router and the br1 VLAN by plugging my computer into port 3 and the main router into WAN, but the other ports do not work.

    Because WAN and port 3 seem to work, I know that this is not a port-ID-to-software-ID misassignment issue mentioned in other threads.
     
  3. DaAwesomeP

    DaAwesomeP Network Newbie Member

  4. pomidor1

    pomidor1 Reformed Router Member

Share This Page