Asuswrt-Merlin on Netgear R7000

Discussion in 'Other Firmware Projects' started by XVortex, Mar 27, 2015.

  1. immetjes

    immetjes Serious Server Member

    Hahaha, you are blocking Fortnite? Why? Perhaps start talking with your children...

    ....I never understand blocking internet for children. Explain things and discuss. Censoring is so easy...
     
  2. Nitin Vaid

    Nitin Vaid Reformed Router Member

    using the latest version i am giving try to it
    but i have noticed that my Internet LED is not working its off sometimes it works sometimes it not what can be the issue?
     
  3. infinitize

    infinitize New Member Member

    hi all. beginner here in overclocking the router. i am on 384.6 and have no clue how to overclock.
    two things i tried doing was going to tools > run command and running the following commands:
    nvram set clkfreq=1200,800
    nvram commit
    reboot

    i even went to goodies-asuswrt's github Overclock Asuswrt Merlin on v378.56 and beyond but i have literally no idea how to interpret what is going on. what do i have to do?
     
  4. slidermike

    slidermike Addicted to LI Member

    OC at your own risk.
    OC is dynamic.
    In otherwords you dont have to reboot for it to go into effect.
    You DO have to run the command from a SSH session NOT the gui command line.
    SSH into your router.
    (using the same user/password as gui).
    Then run
    nvram set clkfreq=1200,800
    Just doing the above puts the router into the OC.
    If its stable for some time, you can make this permanent by doing the following.
    nvram commit
    If the router isnt stable before you commit the change to memory you can just power cycle it so it returns to default 1000,800
    Its your choice.
     
  5. infinitize

    infinitize New Member Member

    thanks for the hasty help! that was really easy to do!
    what is considered "stable"? any preferred temperature readings? what happens if it's unstable?
     
  6. slidermike

    slidermike Addicted to LI Member

    stable means the router is doing what it is expected to do without odd behavior.
    If you OC too high (for your hardware) then all kinds of odd behavior might be seen such as no networking, router not booting up, constant rebooting.
    Typically the R7000 is OC for most users safely to 1200,800
    Some go for 1400,800 but that is stable for less users.
    Its a OC at your own risk game.
    Thats why its best to OC it but not write it to memory.
    That way if it flakes out you can just power cycle it back to default 1000,800
    Once your satisfied with the OC then you can write it to mem.

    If your not OC for a specific reason such as faster VPN or some of the other things that benefit from faster cpu speeds then there really is no reason to OC the router.

    As for temps, some folks plug a usb based fan into the usb port and let the router run its own external fan over the air vents. Inexpensive laptop fan trays are popular choices.
     
  7. badplay

    badplay Network Newbie Member

    hi i have installed diversion and it looks and works i thing good i added pixelserv dont knw if it works. becorse i see some ads always from google or ather things is it normal?

    and is there a way to add a whiteliste ip? so i have full ads on some of my devices???? like smartphone?

    in the diversion Thread i cant ask becorse it is illegal to use on a non asus router :(

    alsow do i flashed correct i have r7000 i flashed the R7000_380.70_0.trx becorse i cams from a older version then i made a factory reset and then in installed newst version trx

    is that correct or do i have to flash the R7000_380.70_0.chk ??? in the instruction they dont tell if chk or trx

    it looks like all works fine
     
  8. bac123

    bac123 New Member Member

    [​IMG]
    hello everyone
    i am using r7000 flashed merlin 384.6 firmware
    the openvpn server running
    but there are unknown ip (from other country) try to connect my openvpn server
    anyone have idea??
     
  9. juched

    juched Serious Server Member

    What VPN port are you using? Try changing it to a different number.
     
  10. Makaveli

    Makaveli Networkin' Nut Member

    Pretty simple answer some children don't listen.

    Its called parenting.
     
    Stimpy88 likes this.
  11. SignedAdam

    SignedAdam Serious Server Member

    384.6 - r7000 - internet LED turns off even when a connection is active bug

    * turning the internet connection on and off seem to fix the problem, or was it a reboot, any way after a few days the bug comes back again
     
  12. joostnl

    joostnl New Member Member

    Code:
    Sep 10 10:46:43 ovpn-server1[730]: 115.166.43.251 TLS Error: TLS handshake failed
    Sep 10 10:46:43 ovpn-server1[730]: 115.166.43.251 SIGUSR1[soft,tls-error] received, client-instance restarting
    Sep 10 10:46:44 ovpn-server1[730]: 115.166.43.251 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
    Sep 10 10:46:44 ovpn-server1[730]: 115.166.43.251 TLS Error: TLS handshake failed
    Sep 10 10:46:44 ovpn-server1[730]: 115.166.43.251 SIGUSR1[soft,tls-error] received, client-instance restarting
    Sep 10 10:46:45 ovpn-server1[730]: 115.166.43.251 TLS: Initial packet from [AF_INET6]::ffff:115.166.43.251:53, sid=6a22eb44 5adb63fe
    Sep 10 10:46:46 ovpn-server1[730]: 115.166.43.251 TLS: Initial packet from [AF_INET6]::ffff:115.166.43.251:80, sid=6a22eb44 5adb63fe
    Sep 10 10:47:45 ovpn-server1[730]: 115.166.43.251 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
    Sep 10 10:47:45 ovpn-server1[730]: 115.166.43.251 TLS Error: TLS handshake failed
    Sep 10 10:47:45 ovpn-server1[730]: 115.166.43.251 SIGUSR1[soft,tls-error] received, client-instance restarting
    Sep 10 10:47:45 ovpn-server1[730]: 115.166.43.251 TLS: Initial packet from [AF_INET6]::ffff:115.166.43.251:53, sid=6a22eb44 5adb63fe
    Sep 10 10:47:46 ovpn-server1[730]: 115.166.43.251 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
    Sep 10 10:47:46 ovpn-server1[730]: 115.166.43.251 TLS Error: TLS handshake failed
    Sep 10 10:47:46 ovpn-server1[730]: 115.166.43.251 SIGUSR1[soft,tls-error] received, client-instance restarting
    Sep 10 10:47:48 ovpn-server1[730]: 115.166.43.251 TLS: Initial packet from [AF_INET6]::ffff:115.166.43.251:80, sid=6a22eb44 5adb63fe
    Sep 10 10:48:45 ovpn-server1[730]: 52.189.222.171 TLS: Initial packet from [AF_INET6]::ffff:52.189.222.171:30100, sid=6a22eb44 5adb63fe
    Sep 10 10:48:45 ovpn-server1[730]: 115.166.43.251 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
    Sep 10 10:48:45 ovpn-server1[730]: 115.166.43.251 TLS Error: TLS handshake failed
    Sep 10 10:48:45 ovpn-server1[730]: 115.166.43.251 SIGUSR1[soft,tls-error] received, client-instance restarting
    Sep 10 10:48:48 ovpn-server1[730]: 115.166.43.251 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
    Sep 10 10:48:48 ovpn-server1[730]: 115.166.43.251 TLS Error: TLS handshake failed
    Sep 10 10:48:48 ovpn-server1[730]: 115.166.43.251 SIGUSR1[soft,tls-error] received, client-instance restarting
    Sep 10 10:49:45 ovpn-server1[730]: 52.189.222.171 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
    Sep 10 10:49:45 ovpn-server1[730]: 52.189.222.171 TLS Error: TLS handshake failed
    Sep 10 10:49:45 ovpn-server1[730]: 52.189.222.171 SIGUSR1[soft,tls-error] received, client-instance restarting
    Sep 10 10:49:47 ovpn-server1[730]: 52.189.222.171 TLS: Initial packet from [AF_INET6]::ffff:52.189.222.171:30100, sid=6a22eb44 5adb63fe
    Sep 10 10:50:47 ovpn-server1[730]: 52.189.222.171 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
    Sep 10 10:50:47 ovpn-server1[730]: 52.189.222.171 TLS Error: TLS handshake failed
    Sep 10 10:50:47 ovpn-server1[730]: 52.189.222.171 SIGUSR1[soft,tls-error] received, client-instance restarting
    Sep 10 10:50:47 ovpn-server1[730]: 52.189.222.171 TLS: Initial packet from [AF_INET6]::ffff:52.189.222.171:30100, sid=6a22eb44 5adb63fe
    I have exactly the same problem, and I'm new to OPENVPN.
    How is this possible? I thought openvpn was very safe with a key file and username/password combination.
    I see a user connected: UNDEF
    Is there automaticly a port forwarded? (I didn't find a forward)
    At vpn server settings i left everything standard, ip adress not filled in UDP 1194
    I use my external ip adress in the key file

    Thanks in advance.
     
  13. juched

    juched Serious Server Member

    Looks like attempts to connect but they are unsuccessful. I would change from the default port to something else.
     
  14. immetjes

    immetjes Serious Server Member

    Never mind.
     
  15. slidermike

    slidermike Addicted to LI Member

    You change ports if you want to but a port scan typically reveals what you have open so that's more of an obfuscation than protection.
     
    Makaveli likes this.
  16. juched

    juched Serious Server Member

    It is expensive to port scan all ports. So most only scan common ports or first 1024 ports. Set higher than 1024 and it should reduce the noise.

    Agree. This is obfuscation.
     
    Last edited: Sep 11, 2018
    Makaveli likes this.
  17. Mezrein

    Mezrein Reformed Router Member

    Is there a way with this firmware to create multiple ssid's and assign them to various bands of the wifi? I know by default I have two, one for 2.4gh and one for 5gh, can I create additional ones?
     
  18. slidermike

    slidermike Addicted to LI Member

    You can add guest ssid's.
     
  19. TRIUMF

    TRIUMF Reformed Router Member

    Does anyone a working configuration of VLAN:
    Need to create separate VLAN with WiFi and 3rd physical port. This VLAN should not be able to talk with my main LAN, but can talk between clients on the same VLAN and have internet access. Also own subnet with dhcp. I have it working on Tomato Shibby, but don't know how exactly do it using command line in Merlin. Any example would be appreciated.
     
  20. slidermike

    slidermike Addicted to LI Member

    Sadly no but if you peruse the SNB forums and search for vlan you should get a plausible guide.
    I don't recall seeing that particular topic laid out in this thread but I have seen it discussed over there on a couple of occasions.
    You can post a guide here once you have it figured out, for the next guy.
     
  21. Makaveli

    Makaveli Networkin' Nut Member

    This thread maybe a good place to start.

    https://www.snbforums.com/threads/f...guest-network-for-asus-merlin-rt-ac68u.18969/

    But also remember this router is not supported on that forum.
     
    slidermike likes this.
  22. Sl4fko

    Sl4fko Network Newbie Member

    I have really strange problems with 2.4 GHz radio on my R7000.

    It seems something is wrong with it, I can not connect to 2.4 GHz signal, no matter which channel, mode (20/40) I choose... Could it be, that I was tinkering with CFE (factory firmware from xwrt and back, I had to edit it...). The signal is broadcasting and is seen in InSSIDer or by clients generaly... I have latest 384.6 firmware installed.

    Any ideas?
     
  23. slidermike

    slidermike Addicted to LI Member

    Please post screen shots of the wifi settings pages. Should be 2, basic and advanced.
    My guess is your using a channel outside of your devices ability to use.
     
  24. Sl4fko

    Sl4fko Network Newbie Member

  25. Sl4fko

    Sl4fko Network Newbie Member

  26. Patrick Walden

    Patrick Walden Connected Client Member

    Hello to all,

    So I'm having a random issue w/ my VPN rules.. A while back, maybe a year ago now, I didn't have to enter anything in this chart and everything went through the VPN. Then, it stopped work about 6+ months ago, and was told to add this rule at the end of my rules:

    <see image 1>

    So I did that, and it worked fine. I could have lines above, i.e. set my Roku on ip 10.0.0.82 to bypass the VPN to use the WAN like this:

    <see image 2>

    this is no longer working. Now that WAN connection turns off, it doesn't go through the VPN -or- WAN.

    Any ideas or things I should try? Any help would be much appreciated.

    ..one more speedbump till the weekend :)
    -Pat
    Im using Diversion/Dnscrypt-proxy/Skynet. Tried disabling diversion and skynet but got nothing..dnscrypt maybe?
     

    Attached Files:

    • 1.JPG
      1.JPG
      File size:
      42.8 KB
      Views:
      18
    • 2.JPG
      2.JPG
      File size:
      43.9 KB
      Views:
      18
  27. Patrick Walden

    Patrick Walden Connected Client Member

    3.JPG Capture.JPG 3.JPG Capture.JPG Here are more settings (to any awesome people who want to help me w/ this I'm happy to get you more):
     
  28. khandu

    khandu Reformed Router Member

    Hey guys.

    I am on latest NG Branch: 384.6

    I am trying to reset it back to stock firmware. Latest on Netgear site is R7000-V1.0.9.34_10.2.36

    I downloaded it and then try to upload it via firmware upgrade page. It says uploading and finishes. And then nothing happens. The router remains on 384.6. Trying on Chrome on a Mac. Also tried Safari.

    What am I missing here and how to reset the router back to stock firmware?
     
  29. ringlord

    ringlord Network Newbie Member

    Check the first post "Link to the "back to stock" firmware ...More recent version (v1.0.9.26_10.2.31) for NG build..."

    Also heed the warnings as to not brick your router and not try to flash things without reading the manual.
     
  30. Sl4fko

    Sl4fko Network Newbie Member

    WAIT!!!

    Do not flash back to stock right away, it can be VERY complicated to access telnet and fix the CFE, if you do...

    Do these commands via SSH first (putty program):
    nvram get board_id
    nvram get serial_no

    If it show some random symbols - then you have corrupted CFE settings.
    This corruption will follow to next FW what ever you install.
    You can fix it in current FW nvram, but if you install newer version of XWRT or stock FW they will appear again.

    I seriously recommend to you ALL, who want to go back to stock to check this #5420 post first; thanks to Terijan01, I saved my router.

    Terijan01, thanks again...
     
    Last edited: Sep 24, 2018
  31. khandu

    khandu Reformed Router Member

    without realising I've flashed R7000-V1.0.9.26_10.2.31.trx but have lost telnet / ssh and can't see any option to enable it. Even after google and going into debug.htm and enabling dev and restarting I can't ssh -p 23 192.168.1.1 (no port open)

    Unable to upgrade it to R7000-V1.0.9.34_10.2.36.chk as it says wrong file.

    What's the best way to fix it? Just want to get it in stock state so that I can sell it and the next person can upgrade normally.
     
    Last edited: Sep 25, 2018
  32. pomidor1

    pomidor1 Networkin' Nut Member

  33. khandu

    khandu Reformed Router Member

  34. ymom411

    ymom411 Reformed Router Member

    I find it interesting that you mention Telnet. I'm on 384.6 and have never tried to flash back to stock, but I cannot find the "enable telnet" option in the Web ui. I can find "Enable SSH" and when I do that, I still see no Telnet option. Any ideas?
     
  35. slidermike

    slidermike Addicted to LI Member

    ymom, discussions about telnet in reverting refer to telnet in the stock firmware. Not in the Merlin NG firmware.
     
    Makaveli likes this.
  36. ymom411

    ymom411 Reformed Router Member

    I think I'm just confused, so let me rephrase. I'm on NG Branch: 384.6 and I am trying to use Putty to Telnet into the router and I keep getting a "connection refused error". I suspect it is because I have not enabled Telnet from within the Web interface. I've looked everywhere and I cannot find that option. I thought I would be able to find it where "enable SSH" is located, but no luck. Can you point me to the tab that will allow me to enable Telnet?
     
  37. Sl4fko

    Sl4fko Network Newbie Member

    Not to worry, you can run all commands also via SSH.

    I really recommend to everyone to check first if you have screwed CFE values to do these commands in post #5420 via SSH first AND THEN GO BACK TO STOCK.

    IT WILL SAVE YOU A LOT OF TIME AND NERVES...
     
  38. juched

    juched Serious Server Member

    I don’t believe the burn commands exist on the ASUS firmware. You need to go back to stock and then telnet in to fix this. This may be available via the debug page or you may need to use a program like telnetable to do this. Then you can run the burn commands and move around as needed.

    Also, Asus firmware doesn’t have telnet, just ssh. Use ssh, it is much more secure.
     
    Makaveli likes this.
  39. juched

    juched Serious Server Member

    Can’t. Just use ssh.
     
    Makaveli and slidermike like this.
  40. slidermike

    slidermike Addicted to LI Member

    juched is correct. In all newer Asus code you are only allowed ssh. Simple
     
  41. ymom411

    ymom411 Reformed Router Member

    Thanks to everyone for pointing me to SSH. Learn something new every day.
     
  42. khandu

    khandu Reformed Router Member

    This is where I am stuck. I didn't find the burn command and thus went to stock. But I haven't been able to telnet. Even if I can, Sl4fko said that the MAC on the box will not work. Is there no other way to find out the MAC which I need to burn to the router? Apart from buying any additional hardware for it?

    If I leave the router as is - what is going to happen? Simply can't upgrade stock firmwares or go back to xwrt firmware? But should function as a normal router?
     
  43. mheddings

    mheddings New Member Member

    I recently purchased a Netgear R7000P am I able to load XWRT on this router?
     
  44. Sl4fko

    Sl4fko Network Newbie Member

    No, you can not do it...
     
  45. Sl4fko

    Sl4fko Network Newbie Member

    UPDATE ON SAVING YOUR ROUTER!

    I just managed to enable the telnet on my R7000 with stock firmware by first running a "WIFI Analyzer" app on my android phone while connected to my wifi signal. The app shows you the signal you are connected to AND MAC ADDRESS OF THE RADIO YOU ARE CONNECTED TO!!! Write the MAC down and connect to the SAME RADIO with your computer/laptop. After you are connected to it, do these steps:


    1.) First go to http://192.168.1.1/debug.htm or http://routerlogin.net/debug.htm (this link worked in my case on my R7000...) You may need to use your router login.
    * check "dev" and press "Restart RA Process".
    * Reboot router via http://192.168.1.1/start.htm -> Advanced -> Advanced home -> Reboot.

    2.) Once router reboots, open cmd (with administrator rights) in a folder where you unpacked telnetenable.zip
    type this:

    telnetenable.exe <IP> <MAC> <Username> <Password>

    Example:

    telnetenable.exe 192.168.1.1 011A022B033C admin password


    USE UPPERCASE LETTERS FOR MAC!

    After that, wait a little. Then try command "telnet 192.168.1.1" in cmd or run Putty and it should work...

    And now, as in post #5420 by Terijan01, execute all the commands. When finished return the router to "prod" mode and press "Restart RA Process" like in step 1.) above and reboot (after reboot you LOOSE THE ABILITY TO TELNET THE ROUTER. If you need a telnet connection again simply repeat both steps above).

    Now, you can upgrade or update your R7000 to any firmware.
     
    Last edited: Sep 27, 2018
    khandu and slidermike like this.
  46. khandu

    khandu Reformed Router Member

    Well that has always been easy to find.. Mac shows the BSSID of the Wifi connection.

    It worked and i was able to upgrade to latest stock firmware. I am guessing that was it and everything is normal.

    These instructions should really be pinned on first post to make it easy. :)

    Thanks guys.. Now I can sell it off.. Been fun using xwrt for last few years. Will miss it!!!
     
    Last edited: Sep 28, 2018
  47. Aeitto

    Aeitto Reformed Router Member

    Hello everyone. It's been awhile since my last activity, I haven't updated for nearly a year or 2 because everything works smooth.
    I would like to know if that's possible to run torrent client that saves data to mounted drive?
    Something like deluge of transmission with web interface? I found only this
     
  48. Makaveli

    Makaveli Networkin' Nut Member

    That is not a safe practice at all.

    So you left it as is and missed out on 2 years of security updates because its just runs?

    You are a hackers dream!
     
    Stimpy88, Aeitto and juched like this.
  49. clweb

    clweb Network Guru Member

    Well, if your signature is correct you have also a two years old firmware inside. ;-)
     
    Last edited: Oct 1, 2018
  50. Sl4fko

    Sl4fko Network Newbie Member

    So... Is telnet possible on XWRT or not? Tried stock for weekend. And tomato also (cannot choose wifi channels, no AC mode...).

    Now I am back on XWRT. Feels like home...
     
  51. Makaveli

    Makaveli Networkin' Nut Member

    I don't even see my own signature on this forum that's why I've stopped updating it.

    Plus I wouldn't have pointed that out while doing the same thing on my end :)

    I'm always current on firmware's I update as soon as they come out.
     
    Last edited: Oct 2, 2018
  52. slidermike

    slidermike Addicted to LI Member

    As said before, no telnet only ssh.
     
  53. jfazny

    jfazny New Member Member

    Newbie to flashing wireless routers. Was searching for best open source and best GUIs and had seen ASUS-Merlin for my R7000. However was scared away when I read that X-Vortex ASUS-Merlin is illegal - I believe unregistered or something worded like that. I didn't ask more on that sight as they were clearly DD-WRT fans. I'm just curious whether this code is or even can be "illegal" in any way? I'm preparing to flash my R7000 and put it behind a new purchase ASUS AC2900, but still unsure which way to go. Opinions, especially from XVortex would be greatly appreciated. Apologies if this post is in any way inflammatory as that is def not its purpose.
     
  54. Sl4fko

    Sl4fko Network Newbie Member

    Of course it is illegal in the means of using GUI and system that is being developed by ASUS for THEIR routers only. However, I think that ddwrt and other firmware users are also a bit exaggerating. If you are only an end user, consumer, using the router for your own private purposes, I do not see, why you should be scared of anybody or anything. You can do with your router what ever you want...

    However, support for xwrt firmware is only here... :D
     
  55. RMerlin

    RMerlin Network Guru Member

    Asus are paying Trend Micro and Tuxera for the rights to use their proprietary products on specific models. There are a few other partners as well (like WTFast). Reusing those components on unlicensed hardware is what's illegal there.

    The danger is not that you (the end-user) will get sued or anything. The danger is that Trend Micro and Tuxera might file a complaint with Asus about misuse of their products, and force Asus to ensure that third parties are no longer able to use these licensed products on unlicensed hardware. That will not only leave Xvortex users out of their firmware alternative, but it will also force me to shut down my own project, and leave oall of my users out of a firmware alternative as well.

    This isn't as far-fetched as you might think, since already Asus had to take steps to limit the damage, which has had a negative impact on my own project. And I know that there's already been one of these partners (which I won't name) that filed an official complain with Asus last spring. We already got VERY close to getting everything shut down then because of this. Apparently they were able to somehow placate them.

    And on top of that we can add the GPL licensing violation, where the victim is not only Asus but also myself.

    So no, this has nothing to do about people telling you this being "DD-WRT fans", because it all comes down to me, the first potential victim of this, warning everyone about this.
     
    slidermike likes this.
  56. Sl4fko

    Sl4fko Network Newbie Member

    OK, I get it.

    And a solution? Stop using the firmware? Mass boycott not to download the firmware?
     
  57. RMerlin

    RMerlin Network Guru Member

    The real solution is for Xvortex to strip all those proprietary components, and to start publishing his GPL code to the public.
     
    Stimpy88, gaselar and lancethepants like this.
  58. ringlord

    ringlord Network Newbie Member

    For my understanding, if all proprietary components would be stripped, would the router still work?

    I don't use special functionality on my R7000, I even only use it in AP-mode.
    But it is so much more stable than on Stock firmware, would hate to loose that.
     
    phalkon30 likes this.
  59. RMerlin

    RMerlin Network Guru Member

    None of these are mandatory to the router's working. The Tuxera NTFS driver for instance can be replaced with NTFS-3G.
     
    phalkon30 and ringlord like this.
  60. jfazny

    jfazny New Member Member

    If I load latest on R7000, will it support AiMesh? I just purchased an ASUS AC2900 to replace my R7000 as ISP-facing router. Looking into allowing easy movement of devices between APs. Recommend AiMesh or a different config - not ASUS-proprietary-based?
     
  61. Makaveli

    Makaveli Networkin' Nut Member

    The Best Mesh routers are listed here.

    https://www.techradar.com/news/best-wireless-mesh-routers.

    If I were to choose one for myself I would go with the Netgear Orbi
     
    jfazny likes this.
  62. XVortex

    XVortex Networkin' Nut Member

    We are live in a non-ideal world.
    In an ideal world, we all would use ideal routers with ideal firmware and would ideally follow the GPL.
    But it is not.
    I do not encourage ANYONE use my/Merlin's/ASUS firmware, and buy a R7000 specifically for crossflash,
    but if you have already bought it and are unhappy with the stock firmware, I just offer you an alternative.
    To accept it or not is up to you.
     
    KingP1n, jfazny, David1 and 3 others like this.
  63. Frank2

    Frank2 Networkin' Nut Member

    Actually, I think the real solution would come from someone developing an open source alternative, that has a really cool interface like ASUS (not like DD-WRT or others). I loved using DD-WRT with all its features. However, the only reason I use this FW is that the GUI is pretty awesome. I don't use any of the proprietary components (I thought they were all disabled [by XVortex])
     
    jfazny likes this.
  64. XVortex

    XVortex Networkin' Nut Member

    BWDPI, AiCloud and AiMesh (still not working properly though) are all disabled by default.
    Its enabling and usage depends on your conscience ;-)
     
  65. GDT78

    GDT78 Serious Server Member

    Just flashed 384.7, all seems sto be ok.
    Thank you XVortex!
     
    KingP1n likes this.
  66. KingP1n

    KingP1n Network Newbie Member

    Same here...awesome job.
     
  67. highkick05

    highkick05 New Member Member

    having a lot of problems on R7000, specifically with Wireless AC 5G .. Constantly dropping out.

    I have never damaged the unit. It has never been dropped. Flashed always with Merlin firmware.

    Is there any way to stop this happening as it actually seems to be getting worse with every firmware release?

    I thought it would dissapear once I updated. :eek:

    Have held the reset button and reflashed once. Seemed a little better , but as soon as I started making changes to binding ip's , boom wireless 5G side went down again.

    Right now I am connecting using wireless N on my ASUS PCE-AC68 adapter (quite a powerful pcie card), because like I said . multiple PCs in the hosue can't see the 5G network anymore. It keeps crashing.
     
  68. Joolsc

    Joolsc Network Newbie Member

    The QOS Statistic chart doesn't seem to work in 384.6 and 384.7, I load the QoS Statistic page after a reboot, the graphic will update itself, then it slowly countdown to 0 in pps then it doesn't update again.

    380.7 works.
     
    Last edited: Oct 11, 2018
  69. Joolsc

    Joolsc Network Newbie Member

    Try the site survey, then manually set the channel to avoid overlap.
     
    phalkon30 likes this.
  70. highkick05

    highkick05 New Member Member

    Bit new to this page. What is site survey?

    You mean set different channel bandwidth ? or mode? What would be ideal in Australia for N and AC?

    I thought this was all done automatically nowadays.
     
  71. highkick05

    highkick05 New Member Member

    Ok got it 'site survey' in the Asus wireless page. ALl it gives is contrl channel. Doubt it's that easy to fix right.

    Hmm will choose random specific channels and see what changes. Thanks.

    Wow, changed the AC channel to something really high, 153, and boom she came up. Connected and everything fine.

    Cheers.
     
  72. Joolsc

    Joolsc Network Newbie Member

    Sorry about that, I didn't give out specific instructions. Glad you figured it out and is working for you.
     
    highkick05 likes this.
  73. juched

    juched Serious Server Member

    Updated to 384.7. Will see how stable it is. 384 has been very good for me.
     
  74. Joolsc

    Joolsc Network Newbie Member

    Can anyone confirm if AIProtection is blocking malicious sites, 2way prevention etc.. and QoS chart is working? As both are not reporting anything. Also trying to figure out if these features are strictly for ASUS routers.
     
  75. peyton

    peyton Network Guru Member

    Not using those features. Can't reply. Sorry.
     
  76. KingP1n

    KingP1n Network Newbie Member

    Plz test and let us know. I dont use those feautures as well and i dont think they might not work properly.
     
  77. juched

    juched Serious Server Member

    I use to try those services and never saw any activity. It seems to me (and rightly so) that this firmware the AIProtect, Adaptive QoS and other BDWAPI features do not function.

    I have done a factory reset months ago and never enabled those features anymore.
     
  78. Joolsc

    Joolsc Network Newbie Member

    The QoS and QoS Statistic chart works in 380.7, I didn't stay on this firmware for too long as most of the builtin tools seems out of date.

    Since 384.6, x.7
    - The Adaptive QoS seems to work, QoS Statistic chart stops updating the numbers as they countdown. However, when switched to Traditional QoS, the chart works.

    - AI Protection doesnt report anything, and since I have adblock servers, browser extension, using cloudflare dns server its hard for me to test. In addition, I installed Skynet addon and that appears to be blocking IP and ports.

    - I used DNS Filter in 384.6, and that works. Its a pain to use if you have DNS setup like mine. For 99% of the users it works (I only use it to divert to different DNS server).

    - OpenVPN server works, very easy to setup

    From mobile app
    - Parental Control appears to work, it does stop my internet

    Summary, yes I do believe its better than R7000 stock firmware even without using these ASUS features. If you want all these features as an All-in-one protection, probably sell the R7000 and get a real AC68U.
     
    KingP1n likes this.
  79. qamartheone

    qamartheone Serious Server Member

    which qos wuld u recommend if i m on 384.7 adap or trad?
     
  80. slidermike

    slidermike Addicted to LI Member

    The tradional QoS has been "fixed" for the last couple of code releases in the Asus firmware.
    So if you wanted to NOT use the DPI features then that's the only QoS you would run.
    If you don't care if you use the DPI features or not then you can also run the adaptive QoS. There is an adaptive QoS "tweak" by one of the guys over on SNBf which allows for custom control of the queues.
    DPI is the closed source 3rd party (paid) features in Asus firmware.
     
    Stimpy88 and qamartheone like this.
  81. Joolsc

    Joolsc Network Newbie Member

    KingP1n and slidermike like this.
  82. Joolsc

    Joolsc Network Newbie Member

    If anyone else is interested.

    I tried AI Protection in firmware 380.7, 384.5, 384.6 and 384, turned on 3 scan features, none of them reports anything, nor will send email notification.

    If you are willing to "play around" then you can install these "addons" (will need an USB drive)

    FreshJR (Adaptive QoS)

    https://www.snbforums.com/threads/r...ements-custom-rules-and-inner-workings.36836/

    AMTM (Menu system for following addons - Optional)

    https://github.com/decoderman/amtm

    Diversion (Adblock)

    https://www.snbforums.com/threads/diversion-the-router-adblocker.48538/

    Skynet (Firewall)

    https://www.snbforums.com/threads/s...mic-malware-country-manual-ip-blocking.16798/

    I have installed all these addons and they do work on R7000.

    Worth the read at

    https://github.com/RMerl/asuswrt-merlin/wiki

    The reason why I was curious about the Ai Protection features is, the Skynet addon reports brute force attacks on the router (alot of acitivities). I expect not many have this firewall addon installed and you are really leaving yourself vulnerable without/with AI Protection which doesn't seem to work in the background.

    Hence, better to have some protection than none. :)

    One very important note. Merlin (ported) firmware AKA Xvortex on R7000 is not officially supported. Dont mention of R7000 running Merlin at SNBF.
     
    Last edited: Oct 17, 2018 at 9:13 PM
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice