Asuswrt-Merlin on Netgear R7000

Discussion in 'Other Firmware Projects' started by XVortex, Mar 27, 2015.

  1. Nick St

    Nick St New Member Member

    Not sure if I did this correctly or not. Used the "back to stock" firmware, the newer one and got it up to 380.65. Factory defaulted it, then tried the most recent netgear firmware .chk. Still getting the invalid message. Is there something simple I'm overlooking?
     
  2. slidermike

    slidermike Addicted to LI Member

    Nick,
    I'm not sure what steps your taking but it is just as simple as the OP directions.
    Link to the "back to stock" firmware (v1.0.3.80_1.1.38) is here.
    More recent version (v1.0.9.26_10.2.31) for NG build is here.


    Once you get "back to stock" (from the above) installed on the router, then install the factory firmware as normal.
     
  3. Nick St

    Nick St New Member Member

    At this point I have the NG build installed, shows as firmware 380.65. However, if I try to upload firmware from Netgear, I get a message about "Invalid firmware upload." So as of right now I'm stuck, and I wasn't sure if maybe it's a version thing? I'm trying to upload "R7000-V1.0.9.28_10.2.32.chk."
     
  4. hellraiser

    hellraiser New Member Member

    Hi,

    I am on latest stock firmware.when i try to Flash the R7000_xxx.xx_x.chk file via the web interface. i get this error

    "This firmware file is incorrect! Please get the firmware file again and make sure it is the correct firmware for this product."

    Please help me friends. Thanks
     
  5. CPB111

    CPB111 Reformed Router Member


    Ive got these listed...


    Asus Devices:
    RT-AC66U (new)
    RT-N10 (new)
    RT-N10E (new)
    RT-N10U (new)
    RT-N56U (new)
    RT-N66U (new)

    So maybe we have a problem.
     
  6. ringlord

    ringlord New Member Member

    Up until v380.70 you are still on 'legacy' branch.
    NG builds starts at v384.x
    So first go back to stock (Link to the "back to stock" firmware (v1.0.3.80_1.1.38)
    Then flash Netgear FW
     
  7. Makaveli

    Makaveli Networkin' Nut Member


    No we don't because none of those on the list is the RT-AC68U which the R7000 shares the same hardware with.

    Which Slidermike already mentioned above.
     
    slidermike likes this.
  8. tapasr_56d18fd83b51b

    tapasr_56d18fd83b51b Network Newbie Member

    You have to use the R7000_xxx.xx_x.trx file.
     
  9. hellraiser

    hellraiser New Member Member


    i tried .trx file too... got same error message.
     
  10. Makaveli

    Makaveli Networkin' Nut Member

    If you have any USB drives attached to the router pull them out also.

    And the trx file should only be used when you are already on Vortex and upgrading to a newer version.

    If you are on Stock Netgear then the chk file is the correct one as per the instructions on the first page.
     
    slidermike likes this.
  11. David1

    David1 Connected Client Member

    I wouldnt completely rule out the vpnfilter malware on our routers just yet, maybe not on the list yet
    not alot of information is provided about the malware

    https://www.reddit.com/r/HomeNetwor...d_unknown_vpn_on_my_router_was_router_hacked/

    apparently the asus android app (old) had a bug in it which enables the remote management which you should check if its disabled
     
    phalkon30 likes this.
  12. slidermike

    slidermike Addicted to LI Member

    +1 to the usb drive Makaveli mentioned. That is a known issue with Asus firmware. Eats into the memory.
    Also, Merlin suggests rebooting after removing any usb drives connected to the router. To recover the memory.
     
    Makaveli likes this.
  13. Makaveli

    Makaveli Networkin' Nut Member

    I agree its not 100% but until we see something listed for the AC68U not quite red alert just yet.

    For now we are still in amber!

    And that Bug i've known about for almost 2 years now. And it was never an issue for me because I always said no at the prompt. The only remote management that I allow is from a VPN connection.
     
  14. hellraiser

    hellraiser New Member Member

    I received email from my internet provider that my router R7000 is infected with vpnfilter malware.

    after that i reset my router, changed default password and remote management was already disabled.

    that's why i am trying to install asuswrt-merlin firmware. i dont want to get infected again.
     
    phalkon30 likes this.
  15. imafish

    imafish Serious Server Member

    Is there a big difference between 384.5 beta 1 and the final version?
     
  16. philipc

    philipc Network Newbie Member

    Have been using 384.5 for weeks, this version is excellent! 5GHz is very stable, for instance.
     
  17. El Barto

    El Barto New Member Member

    384.5 has no QOS ?
     
  18. olegy

    olegy Networkin' Nut Member

    Hello there, just wanted to ask for a suggestion. Currently running Shibby Tomato and since it is no longer supported or updated, I've tried to switch to Xwrt Vortex. Everything runs perfectly with an exception of one thing.
    There is an Xtreamer express media player on my network, which is a hybrid device running on Android and has a OpenWrt Chaos Calmer 15.05 server built in as well. So, after the switch, Xtreamer express cannot see any samba shares on my network in the browse. All windows computers can see each other. Xtreamer express can see DLNA severs, but not Samba shares. If I switch back to Shibby - the browse mode comes back.

    I hope, I just need to change something in config, I just don't know what to change.
     
  19. slidermike

    slidermike Addicted to LI Member

    Im just going to guess but based on your description I would conclude the media player is possibly using an older ver of Samba.
    If it were me, I would search the internet and the media players forums for anyone running the player successfully with Samba on a newer firmware than Tomato like dd-wrt or AsusMerlin. Though Merlin firmware uses the same kernel as Asus stock which I believe isn't as new as dd-wrt.
     
  20. Stimpy88

    Stimpy88 Connected Client Member

    If you have just updated to the latest version of Windows 10, then that has broken SNB v1.0, and could be your problem.
     
  21. Makaveli

    Makaveli Networkin' Nut Member

    so SNB 1.0 is broken in build 1803?
     
  22. sturmi

    sturmi Reformed Router Member

    No, It's not broken - it is now disabled by default. You have to enable it via Windows Features and restart.
     
  23. Stimpy88

    Stimpy88 Connected Client Member

    Users running Windows 10 version 1803 may receive an error "An invalid argument was supplied" when accessing files or running programs from a shared folder using the SMBv1 protocol.


    Enable SMBv2 or SMBv3 on both the SMB server and the SMB client, as described in KB2696547.

    Microsoft is working on a resolution that will be available later in June.

    Further reading...
     
  24. slidermike

    slidermike Addicted to LI Member

    Its appreciated that the windows & SMB was brought up but the OP said when he changes the router firmware (not his PC) is when the older client device has issues accessing the shares. When he reverts back to Tomato the client device share access works again.
    Based on that, it should not have anything to do with Windows 10.
     
  25. Felipe_Motta

    Felipe_Motta Network Newbie Member

    I've got the same problem.
    I've been thinking of flashing the legacy XVortex firmware before flashing the New Generation firmware, but I'm not comfortable trying it with this message.
    I'm running the latest Netgear stock firmware V1.0.9.32_10.2.34.
    Anyone can tell us what to do?

    Thanks in advance!
     
  26. Felipe_Motta

    Felipe_Motta Network Newbie Member

    I could no longer wait. I was really stressed out with Netgear stock firmware. I finally managed to install the last version of XVortex.
    Apparently, although the tutorial says to flash directly the last version of XVortex when coming from stock, you MUST flash the last XVortex legacy firmware before going to New Generation. At least, it worked for me pretty well.
    For new users, the first flash of XVortex lasts forever and freaked me out. Therefore, relax and do not touch it. Just wait.
    Then everything will go just fine.
    Till now, it looks a great firmware.
     
  27. Giorgio3

    Giorgio3 New Member Member

    Hello, I am using Xwrt-vortex 384.4 on my R7000. I would like to enable traffic monitoring, but I can't find it anywhere. The Asus manual shows more options in the main menu than I see.
    Under "General" I only have:
    • Network map
    • Guest network
    • USB application
    • Tools
    In the Asus RT-AC88U user guide the options are (page 38):
    • Network map
    • Guest network
    • AiProtection
    • Adaptive QoS
    • USB application
    • AiCloud 2.0
    The traffic monitoring is supposed to be under Adaptive QoS (as shown on page 41).

    Does Xwrt-Vortex have traffic monitoring? If so, where can I find it?
     
  28. Ubimoo

    Ubimoo Reformed Router Member

    "Enable BWDPI" under "Tools - Other Settings" and then reboot
     
  29. Giorgio3

    Giorgio3 New Member Member

    Thanks. BWDPI: I never would have found that myself.
     
  30. Makaveli

    Makaveli Networkin' Nut Member

    Use the search function in the forum its pretty handy.
     
    slidermike likes this.
  31. Giorgio3

    Giorgio3 New Member Member

    You made the wrong assumption. I did use it. WIth the search terms "monitor" and "traffic monitor" I just did not find it.
     
    Stimpy88 likes this.
  32. Kramttocs

    Kramttocs New Member Member

    For Dual WAN is it still accurate that ONLY the usb modems listed from the link within the router on the Apps page work? Was looking at the FreedomPop usb bolt as a backup but it's not listed and I wasn't sure if that list was the only ones that work or the only ones tested.
     
  33. gxcare

    gxcare Network Newbie Member

    I don't know if it has still been reported, but after being disconnected from the WAN due to network problems I guess, it is the second time I observe that the WAN led (the second from left) goes off, then orange but then again off when reconnected. Toggling the WAN off and then on from the switch in the GUI does not show this issue and the led goes back to white.
    I am using 384.5.
     
  34. mpgrimes

    mpgrimes New Member Member

    *DELETED*
     
    Last edited: Jun 19, 2018
  35. Makaveli

    Makaveli Networkin' Nut Member

    I've seen this issue.

    Right now I'm at like 34 days up time and the Wan Light is currently off.
     
  36. KingP1n

    KingP1n Network Newbie Member

    Is QOS statistics page working for you guys on 384.5? I tried numerous time to go back to stock 380.70 and
    QOS stats graphs show without any problem. However, as soon as I install the latest asus 384.5 the qos stats don't work anymore. It doesn't show the graphs and all the numbers reflect 0.00...any ideas?
    System log shows:
    Jun 19 14:06:24 rc_service: rc 8718:notify_rc restart_wrs
    Jun 19 14:06:44 kernel: ERR[parse_qos_conf:932] Can't set new QoS conf while QoS is started!
    Jun 19 14:06:44 kernel: ERR[ioctl_iqos_op_config:3592] parse qos_conf error!!
    Jun 19 14:06:44 kernel: ioctl_iqos_op_config() fail!
    Jun 19 14:06:44 kernel: ERR[qos_start:3344] QoS is already started!
    Jun 19 14:06:44 kernel: ioctl_iqos_op_switch(1) fail!

    I did complete reset after installing the stock asus fw (380.70) and again after installing the asus-merlin fw 384.5...I'm not sure what I'm doing wrong???
     
    Last edited: Jun 19, 2018
  37. slidermike

    slidermike Addicted to LI Member

    factory reset the router?
    Verify any acceleration is disabled (CFE+FA)?
    Have you tried traditional QoS and/or Adaptive QoS?
    Searched the SNB forums for Asus users posting about QoS/NG and statistics?
     
  38. KingP1n

    KingP1n Network Newbie Member

    Yes, I reseted the router.

    Net acceleration was set to 'Auto', I turned it off and I'm using adaptive qos same issue. However when I switched to traditional qos the qos stats page works.

    Does it have to do with adaptive qos?

    Also, you can't have both qos enabled and net acceleration to 'Auto' at the same time correct?
     
  39. slidermike

    slidermike Addicted to LI Member

    I am going to assume you can set acceleration to auto and use QoS but you can test that to verify.
    If QoS is running then your router will most likely NOT be doing any acceleration because it has to inspect each packet for potential QoS marking.

    I don't run the firmware nor run the R7000 as a router. It is an AP in my network.

    The adaptive QoS is a part of the proprietary Trend Micro closed source stuff.
    As such the Asus stat graphs probably cant "see" what the Adaptive QoS is doing to report it.
    Traditional QoS was just recently "fixed" in Asus firmware after years of being broken.
     
    KingP1n likes this.
  40. KingP1n

    KingP1n Network Newbie Member

    Thanks slidermike, yes stas page doesn't work with adaptive qos. I'm trying to run FreshJR scripts and I believe they're working properly, and like you said, the Asus stat graphs probably cant "see" what the Adaptive qos is doing but I'm hoping its working as it should. Thanks for the assist.

    Maybe xvortex can provide some additional info as far as adaptive qos? Like I said, when I install the legacy stock asus FW, adaptive qos and the qos stats page works perfectly. Once I installed the latest fw it stops working....
     
  41. juanjekla

    juanjekla Reformed Router Member

    I have the same problem as you but doing what you say keeps coming to me that the firmware is invalid. Is there any other way to do it?
     
  42. juched

    juched Reformed Router Member

    As I was told the R7000 does not work with adaptive QoS/TrendMicro protection/etc.

    Are you sure adaptive QoS is working for you?


    Sent from my iPhone using Tapatalk
     
  43. Felipe_Motta

    Felipe_Motta Network Newbie Member

    I think it is not a problem with the XVortex firmware, but some change Netgear did in its latest version of stock firmware which is not recognizing this new XVortex firmware as compatible one.
    Unfortunately, I can't tell you if there is another way to flash it.
     
  44. Felipe_Motta

    Felipe_Motta Network Newbie Member

    Issues I've found so far. (R7000_384.5_0.zip)

    1 - (Ai Protection) Time scheduling parental control is not working properly. I tried to block internet traffic of a PS4 (cable), a PS3 (Wifi) and two smartphones, but the router blocks traffic even during allowed periods (intermittently).

    2 - (Ai Protection) Web & Apps Filters is not blocking unwanted websites (Adult Category) and blocking others which are not set to be blocked (Ex: Some MP3 downloads in Google Drive).

    3 - Wan port LED remains off (2nd LED) after you unplug the wan cable and plug it back (However, internet works normally).

    4 - (USB Application) When setting FTP permissions for other users in web interface, the router sets them correctly, but when you come back to see the permissions, they seems to be not set. (Click first on the USB device and after on the user to check the permissions). In Samba section, it's working properly.

    5 - Adaptive QoS and QoS Statistics seems not to work properly. Qos Statistics tab always shows all application classes at zero bytes transferred. Adaptive QoS seems to throttle some connections by mistake. (Ex: Pictures at Instagram and Whatsapp sometimes take too long to be downloaded compared with the 4G smartphone connection. At least, this is my impression).

    6 - In "Tools" Ethernet ports option shows VLAN 1 assigned to ports 1 and 2, even though I've assigned to them VLAN 10. For Port 3 and 4, it correctly shows VLAN 20 assigned as I've set. (Only aesthetic. The VLANs are working fine)

    Despite these issues, I still thing this firmware very good option compared with Netgear's one.

    Does anyone know where we can officially report these errors to help the developer improve the firmware?

    In case I find a new issue, I'll report.

    Thanks
     
    SignedAdam, Stimpy88 and KingP1n like this.
  45. slidermike

    slidermike Addicted to LI Member

    You can post here anything you see but xVortex only enables the porting of the firmware from Asus only routers to those he supports. He isn't actually fixing any bugs or broken features.
    So if its broke, it will likely remain broken until Merlin or Asus fixes an issue on the firmware, then xVortex will port it.
     
    Makaveli likes this.
  46. Stimpy88

    Stimpy88 Connected Client Member

    And don't forget the full reboot for every single minor change you make. And WiFi settings suddenly changing, and WiFi settings reverting to factory settings of you play with the settings too much...

    These bugs have been in the firmware for years now.
     
  47. rarepupper

    rarepupper Network Newbie Member

    Running Merlin 380.70 on R7000.
    I understand this firmware doesn't allow blocking sites on a per-time basis, like Tomato does.
    (aka: Block Facebook from 6:00pm to 10:00pm).

    So, wonder if running a Cron job to block certain sites at certain times would have the same effect?
    If that's the case, are there any guides on how to do it?

    Thanks in advance!
     
  48. Felipe_Motta

    Felipe_Motta Network Newbie Member

    Hi,

    I'm having serious problems with USB HD attached to USB 3.0 port. Every time I reboot the router, it corrupts some MP3 files at random. I've lost many songs during these days.
    Also, SMB speed transfer is absurdly slow. Often, it hits 0 bytes/s and stops.

    It's serious, so I'm backing to stock.
     
  49. sn2018

    sn2018 Network Newbie Member

  50. Mezrein

    Mezrein Connected Client Member

    Hey guys, recently updated to the new NG code, but am having two strange issues. First one has to do with parental controls. When I set the time scheduling to litterally any time, deny or allow, it auto blocks completely and shows that internet is blocked on that device. What step am I missing?

    Second issue, and this has been a persistent issue since 368_4 release.
    Any time I make any change, add someone to wireless mac filtering, remove someone from it, try to configure a guest network, or almost ANY other change from the router ui, my router reboots. Its quite frustrating and almost makes me miss the original router firmware. Anyone got any clues as to why my router is acting so bizarre?
     
  51. Stimpy88

    Stimpy88 Connected Client Member

  52. slidermike

    slidermike Addicted to LI Member

    The router rebooting is a common thing on Asus code. As you noted that "feature" has been around for a long time now. No fix for it I know of.
     
    phalkon30 likes this.
  53. Mezrein

    Mezrein Connected Client Member

    Ugg, sorry for the post guys, was super tired when I did it last night and didnt see the ones on the same friggin page. I really like this firmware, really dont want to go back to netgear firmware because I dont think it has the level of control that this firmware does.. :(
     
  54. phalkon30

    phalkon30 Serious Server Member

    How often do you change settings in your router? For me it's a set it and forget it until I update situation. I think every router I've owned has fine this actually

    Updated to the NG firmware from the old branch over the weekend. Instructions were very clear, the process was super simple! Everything seems to be running smoothly again and I probably formatted out those pesky Russians in the process

    Sent from my Nexus 6P using Tapatalk
     
    Makaveli likes this.
  55. Mezrein

    Mezrein Connected Client Member

    Considering I am using mac filtering to prevent people (read as kids bringing in devices to get around time blocks) I am quite often updating the mac table to allow trusted friends access to my wifi, and since I tend to have to do it on both 2.4 and 5g, its a reboot for each one.. :( While fustrating, I can deal with the reboots, the time block is more of a concern for me.
     
  56. phalkon30

    phalkon30 Serious Server Member

    Fair enough, everyone has their own use cases :)

    Sent from my Nexus 6P using Tapatalk
     
  57. Kramttocs

    Kramttocs New Member Member

    I've tried to find the answer to this but am still unsure: with 3 R7000's going to 384.5 should I use the custom cfe for any reason?

    Longer worded question:

    I have 3 R7000's. 2 repeaters and one router all hardwired together. I upgraded all 3 to 380.70 and then upgraded one of the repeaters to 384.5. I was going to start upgrading the others but then came across a post that talks about AIMesh and issues with the mac addresses. It sounds like AIMesh isn't 100% working right now but to make sure I don't limit myself in the future do I need to put the custom cfe on the other 2? I'll admit I don't fully understand the cfe's purpose on these routers. (I've read the how and why posts)
     
  58. slidermike

    slidermike Addicted to LI Member

    A custom CFE serves only 1 purpose...
    To allow for an Asus style recovery if your router doesn't boot up anymore.
    Nothing else you mentioned about AIMesh or any other function is related to the custom CFE.
     
    phalkon30, Stimpy88 and Makaveli like this.
  59. Kramttocs

    Kramttocs New Member Member

    Thanks a lot. The post below is the one that made me hesitate despite the 'why' post only listing the recovery aspect like you mentioned. Appreciate the response.

    http://www.linksysinfo.org/index.ph...in-on-netgear-r7000.71108/page-55#post-295968
     
  60. kingkhan

    kingkhan New Member Member

    I installed 384.5 on my R7000, and went through the setup process.

    After setting up my WiFi settings, the router no longer boots. I only get an orange power light and a white WAN/internet light.

    Any ideas?
     
  61. slidermike

    slidermike Addicted to LI Member

    1) Full power cycle - pull the power, wait 30 seconds and power it back on.
    2) Factory reset - power down. Put a pin in the reset hole. Power up and keep the pin in place for about 30 seconds then release. The router should then factory reset and boot with factory config.
     
    kingkhan likes this.
  62. kingkhan

    kingkhan New Member Member

    Thanks, I'll give this a try after getting home today

    I also wanted to ask if this FW suffers from the chromecast bug which was affecting earlier firmwares. The router became unresponsive after an hour or so when a chromecast was connected to the network.

    I actually replaced the router because i thought there was an issue with the router.
     
  63. kingkhan

    kingkhan New Member Member

    So I tried the restart it didn't work. I still have the solid orange power LED and no signs of life.


    I even tried bridging the gnd and rx pins to see if that would do it, but nothing.

    How could the router be working one sec, and die after setting up wifi?
     
  64. ringlord

    ringlord New Member Member

    Vlolwut, phalkon30 and Stimpy88 like this.
  65. phalkon30

    phalkon30 Serious Server Member

    That was fixed mainly on the android software side, but regardless I've been running 6 chromecast devices on my network for years with no issue other than the month Google had issues.

    Sent from my Nexus 6P using Tapatalk
     
  66. juanjekla

    juanjekla Reformed Router Member

    I'm stuck in netgear firmware it says firmware file invalidated in all the FW previously had the NG version installed but returned to stocko with the FW that says Vortex from then on does not let me update in any of the cases, I would appreciate any help.
     
  67. Kostas

    Kostas New Member Member

    hi. could you add QOS?
     
  68. Kostas

    Kostas New Member Member

    i find Qos. could help someone how can i change the region to eu? sometimes the wifi 5ghz uses 149 band an i cant see it on my laptop. i searched it in the forum but i dint find something that can help me. could you give some instructions how to do it?
     
  69. slidermike

    slidermike Addicted to LI Member

    Read the original post for changing the region.
     
    Makaveli likes this.
  70. juched

    juched Reformed Router Member

    Keep reading back on this exact thread. The steps to fix with commands built into the netgear firmware are posted here.



    Sent from my iPhone using Tapatalk
     
  71. Kostas

    Kostas New Member Member

    I already dit. I found the instructions. I successfully run ssh with username and password of my router. All ok. I don't know the commands and how to upload the region file. Could you help me?
     
  72. David1

    David1 Connected Client Member

    you dont need to upload any file, just copy and paste the commands one by one and reboot
    as Nikopol89 said he had problems with EU and is using italian

    nvram set wl_country_code=IT
    nvram set wl0_country_code=IT
    nvram set wl1_country_code=IT
    nvram set pci/1/1/ccode=IT
    nvram set pci/2/1/ccode=IT

    nvram set wl_country_rev=0
    nvram set wl0_country_rev=0
    nvram set wl1_country_rev=0
    nvram set pci/1/1/regrev=0
    nvram set pci/2/1/regrev=0

    nvram commit && reboot
     
  73. Mezrein

    Mezrein Connected Client Member

    Can someone explain the time scheduling blocks to me? The hours blocks show up as 04-05 then 05-06. Does that mean if I block 04-05 that from 4am to 5am its blocked, but 5am to 6am is unlocked?
     
  74. sn2018

    sn2018 Network Newbie Member

  75. juanjekla

    juanjekla Reformed Router Member


    do not specify the steps to follow about the invalid firmware only comment that they did but do not say the steps to follow
     
  76. Kostas

    Kostas New Member Member

    how can i disable channels 120, 124, 128, 144,149, 153, 157, 161 & 165 that are not supported in Greece? i used region EU command lines from script folder in page 2 of the threat
     
  77. slidermike

    slidermike Addicted to LI Member

    Makaveli likes this.
  78. sn2018

    sn2018 Network Newbie Member

    I get that. I don't expect xvortex has alpha or beta release except the link mentions someone can't upload merlin alpha release to a TM-AC1900 which is much closer to RT-AC68U than r7000.
     
  79. slidermike

    slidermike Addicted to LI Member

    If you get that then why did you ask
    ”Will we see 384.6 on R7000"
    And link to the alpha thread as the source?
    Guess I don't understand your ask.
    What we know is when Merlin releases a stable code, xvortex ports it.
    Really nothing simpler.
    The r7000 and ac68u are the same hardware.
     
    Makaveli likes this.
  80. phalkon30

    phalkon30 Serious Server Member

    Manually set a channel based on a site survey of what networks are around you. It will be more reliable, and you can pick a channel that works in your region

    I like the android app WiFi analyzer by farproc studios for this, but I'm sure there are others

    Sent from my Nexus 6P using Tapatalk
     
    Stimpy88, slidermike and Makaveli like this.
  81. Frank2

    Frank2 Networkin' Nut Member

    So I was thinking (first mistake): I just moved into a new house. Old, large, with plaster walls. Wifi coverage not as good as the last house with my R7000. So I thought about placing a couple of Ubiquiti AP's in the house. All the Unifi lovers tell me I need to get the Unifi USG to run the AP's. However, the specs on the Unifi USG aren't as good (e.g. processor is slower) as my R7000. Can I use my R7000 as the controller? I love my R7000 performance but am unsure if I can use it that way.

    Thoughts?
     
  82. slidermike

    slidermike Addicted to LI Member

    Frank, buy a couple of used r7000 on eBay.
    Put your fave firmware on them and run them in AP mode.
     
  83. Brandon Nokes

    Brandon Nokes New Member Member

    Hello All,

    I am running 380.68.4 on my R7000. It behaves as though its upgrading the firmware when I try to install 384.5.0 but once it finishes, I login and my router is still no 380.68.4. Is there a secret to getting onto the newer branch firmware?

    Thank you,

    Brandon
     
  84. slidermike

    slidermike Addicted to LI Member

    Follow the simple steps in the OP.
    There is an interim firmware you have to jump to first I believe before the NG firmware.

    The other known issue with Asus firmware is having USB drives attached & running for a while.
    Remove any usb drive.
    Reboot the router and then with a clean rebooted router try the upgrade.
     
    phalkon30 and Makaveli like this.
  85. cybrnook

    cybrnook Addicted to LI Member

    380.70
     
    Makaveli and slidermike like this.
  86. kingkhan

    kingkhan New Member Member

    have an issue with my R7000 that I am hoping the community can help with.



    The router was flashed with the latest Merlin FW and booted up without issue. I completed the setup and inputted my WiFi SSID settings.



    After saving the WiFi settings, the router indicated it had to reboot. Once I hit save, the router never booted back up.



    I only have a solid Orange LED on the power button and 2 other lights that are white. I cannot get into the router and it is not assigining any IP addresses. When connecting an ethernet cable, the LAN LED turns orange to indicate activity, but I cannot connect or get an IP address from the router.



    I tried setting a static IP on my laptop and connecting an ethernet directly to the router to flash a fw using tftp which did not work. As a last resort, I ordered a USB TTL cable hoping to recover the router using that method.



    I connected the TTL adapter in the following method:

    Router TX -> TTL USB RX

    TTL USB TX - > Router RX

    Router GND -> TTL USB GND



    The router LEDs all turn on when connecting the ground, so i tried without the ground, and i get no response from the putty session.

    The behaviour of the router when turned on is the following: All lights turn on, and 1 second later the power LED turns orange and that is all.
     
  87. slidermike

    slidermike Addicted to LI Member

    You can try using the dd-wrt forum R7000 threads to assist in recovery.
    This is from the R7000 faq.
    ^^^ Serial cable ^^^
    If you brick the router or need to watch things load before access to the OS then you will want a serial cable.
    You can google for these key words "USB To RS232 TTL UART PL2303HX Auto Converter USB to COM Cable Adapter Module"
    Also: http://www.dd-wrt.com/wiki/index.php/Serial_Recovery
    With pictures:
    http://www.myopenrouter.com/article/how-debrick-or-recover-netgear-r7000-r6300v2-or-r6250-wi-fi-routers

    From

    https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=264152
     
  88. Frank2

    Frank2 Networkin' Nut Member

    You know what would really be cool;
    If we could import our reserved IP addresses for devices by mac address and icon.

    Part of the reason I don't upgrade often is because I don't want to reassign reserved IP addresses (Manually Assigned IP). Yes, you can export the client list, but there is no way to IMPORT the manually assigned list.

    Just sayin'. Would be a nice feature.

    Thanks for listening.
     
  89. slidermike

    slidermike Addicted to LI Member

    Frank, cant you take your existing config in command line and export it to a file.
    Then search the file for the command line with all the IPs or whatever unique/pluggable value you want.
    Once you have the basic command syntax you can probably tweak it for input.
    I know I used to do that for ddwrt.
     
  90. Xx_iDon_xX

    Xx_iDon_xX New Member Member

    will this work with the r8000? nighthawk x6 r8000? im currently on kong's ddwrt and would like to use this firmware
     
  91. slidermike

    slidermike Addicted to LI Member

    No, go to the OP's OP then from there his link to his page. You can see he only supports a couple models.
     
  92. slidermike

    slidermike Addicted to LI Member

    Blonde moment, move along.
     
    Last edited: Jul 11, 2018 at 3:42 AM
  93. juched

    juched Reformed Router Member

    384.5 is already done a while now. See first post.


    Sent from my iPhone using Tapatalk
     
  94. slidermike

    slidermike Addicted to LI Member

    lol, my bad.
    I didnt pay attention. Thank you xVortex.
    Sorry to ring the alarm bell.
    :)
     
  95. Makaveli

    Makaveli Networkin' Nut Member

    Negative.

    It clearly says R7000.
     
  96. Frank2

    Frank2 Networkin' Nut Member

    Thanks for the response Slidermike. However, I fear you may have placed too much confidence in my abilities to tweak command syntax's. Everything I know about the R7000 and Merlin-Xvortex I learned from you guys, but I haven't had the class on how to do that ;)
     
  97. juanjekla

    juanjekla Reformed Router Member

    Since I returned from the NG version to the stock I can not update any firmware, why? no idea. I've tried a thousand ways and nothing at all even with the serial port ... so I do not know what else to do.
     
  98. Sl4fko

    Sl4fko Network Newbie Member

    Screwed CFE... Dump and edit routers CFE with its stock data (MAC, serial...).
     
  99. Sl4fko

    Sl4fko Network Newbie Member

  100. juanjekla

    juanjekla Reformed Router Member

    Can you help me and take a few steps to follow?
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice