Asuswrt-Merlin on Netgear R7000

Discussion in 'Other Firmware Projects' started by XVortex, Mar 27, 2015.

  1. slidermike

    slidermike Addicted to LI Member

  2. drnorton

    drnorton New Member Member

    So.. I testet the firmware .. I must say..Ilike it much.
    But some things dont work for me. So I sadly go back to dd-wrt kong build.

    - Will be nice to have wifi on off in gui by time.
    - Firewall network service filter need liek in dd-wrt polices for more rules.
    - DNSmasq will be nice in gui for pxe boot.
    - Also cron field.

    All other things are realy nice. Good work.
     
  3. chetansha

    chetansha Connected Client Member

    Thank you


    Sent from my HTC One M9 using Tapatalk
     
    Almighty1 likes this.
  4. Nitin Vaid

    Nitin Vaid Reformed Router Member

    Hello everyone
    My R7000 is set to as repeater mode I have set the IP my self its 192.168.1.1
    Subnet mask is 255.255.255.0 and then the gateway of the other router which its connected
    Everything is worming but
    Now I am not able to login the router address to manage its settings the page is not opening
    Tried the default address too
     
  5. slidermike

    slidermike Addicted to LI Member

    I would verify with my dhcp server that the r7000 isn't really using a dhcp address.
    Are you trying to access the r7000 from a lan/wlan or wan side connection?
    If you connect into the r7000 lan ports and give your pc a static ip just up from the r7000 like 192.168.1.2 can you hit the r7000?
     
  6. Nitin Vaid

    Nitin Vaid Reformed Router Member

    I have tried both lan and wireless connection.
    I'll try to give the PC static ip then I can connect to router but then no internet connection to PC

    And I have one more issue after I restarted the router I can't connect it with WiFi on my mobile device stuck on obtaining IP address..
     
  7. slidermike

    slidermike Addicted to LI Member

    Sounds like you have a configuration or wiring issue.
    Also, since you said the R7000 is in repeater mode please be sure to be specific when you say "router".
    Do you mean the non-described device which is acting as your router or do you mean the R7000 which you said is in repeater mode.

    You have to be very specific when explaining network issues and configurations.
    A diagram never hurts.

    Personally I would probably factory reset the R7000 and go step by step through configuring it again as a repeater.
    See if you missed something.
    First I would configure it with a static IP & also setup the management access settings including ssh & gui.
    Save
    Then put it into repeater mode.
     
  8. Nitin Vaid

    Nitin Vaid Reformed Router Member

    okay in here what should i use manual or Automatic? its after i set the R7000 Router in Repeater Mode and after connecting it to the wifi i want to repeater what should be the settings here.PNG
     
  9. badplay

    badplay Network Newbie Member

    i love that software i have installed Firmware:380.68_2

    now i see it got a small fixed update with security fix. how i easy update ??
     
  10. slidermike

    slidermike Addicted to LI Member

    download the latest ver. Unpack it. Click on the current version link in the gui and then choose to update. Browse to where you saved the file and apply.
    The router will update and reboot.
     
  11. badplay

    badplay Network Newbie Member

    done

    it looks like it is all finde how can i check if all is fine??

    after a big update 2 month ago i run in some issues. but for now it looks like all works
     
  12. drnorton

    drnorton New Member Member

    Hello..

    Looks like OpenVPN and Access Resctrictions
    dont work together in dd-wrt and it will be not changed
    I think...

    So I like to use xwrt. But there is a trouble with the firewall gui and no access restrictions.

    Now I am thinking about to do this restrictions by scripts and with iptables. Now my question.
    Runs timestart and timestop and mac adresses in xwrt ? Maybe this is a way.
    But it will be nice to have it with GUI.
    Means are they this modules inside the firmware ?
    insmod xt_mac
    insmod ipt_mac
    insmod xt_time
    insmod ipt_time
    Or is the a entware module ?

    I like to block some IP adresses or MAC Adresses.
    And here only some ports. One example:

    One user comes over OpenVPN to the LAN and need this connection to play games, like LOL.
    Now I like to block the ports for this game.
    Means: Ports 27000-27050, Ports 8393-8400,Ports 5222-5223, Port 3478 and 8088. Both ... TCP and UDP
    And this for different times. Not only for one time.

    I looking for a long time to manage this problem.

    thanks....
     
  13. dr.bob

    dr.bob New Member Member

    IPTV-without VLAN + Internet-taged VLAN on all LAN ports

    Hi guys,
    my internet provider gives me Internet in Vlan 1505 + IPTV without vlan. I would like to get Internet + IPTV on all 4 LAN ports and also in WiFi. There are many solutions on forums in case if Interenet and IPTV have different Vlans. But in my case I have interent vlan only. When I create vlan 1505 for internet, the IPTV stop working. When I erase vlan 1505, the IPTV work fine but a have not internet. I do not understand why router stop routing multicast after vlan create.

    ASUSWRT-Merlin R7000 380.68-4 Sun Jul 16 18:49:41 UTC 2017
    admin@R7000:/tmp/home/root# robocfg show
    Switch: enabled
    Port 0: 1000FD enabled stp: none vlan: 2 jumbo: off mac: cc:............
    Port 1: 100FD enabled stp: none vlan: 1 jumbo: off mac: c4:..............
    Port 2: DOWN enabled stp: none vlan: 1 jumbo: off mac: 00:00:...........
    Port 3: DOWN enabled stp: none vlan: 1 jumbo: off mac: 00:00:...........
    Port 4: 1000FD enabled stp: none vlan: 1 jumbo: off mac: 90:............
    Port 5: 1000FD enabled stp: none vlan: 2 jumbo: off mac: e4:.............
    Port 7: DOWN enabled stp: none vlan: 1 jumbo: off mac: 00:00:...........
    Port 8: DOWN enabled stp: none vlan: 1 jumbo: off mac: 00:00:...........
    VLANs: BCM5301x enabled mac_check mac_hash
    1: vlan1: 1 2 3 4 5t
    2: vlan2: 0 5
    1505: vlan1505: 0t 5t

    Thank you for any advice.
     
  14. pablot

    pablot New Member Member

    Hi, I've saw on the Merlin's website that he is now using 382.1 code. Anybody knows if Xwrt-Vortex will be upgraded too?. What will be the benefits of upgrading the code base?

    I'm asking this because I understand that the R7000 has similar hadware to the Asus AC68U, but 382.1 code seems to be for the AC86U (86, not 68) so... can this new codebase be the end of the AC68U (and R7000) support?
     
  15. slidermike

    slidermike Addicted to LI Member

    pablot, if you keep up over on the snb forums then you will also have seen what Merlin said about why only some models have the newer code.
    Currently the XVortex flavor is the most current that the ac68u is covered under so I don't expect an update until that gets updated by Merlin first.
     
  16. pablot

    pablot New Member Member

    Sorry, didnt' saw that, Can you share the url thread so I can read about that?
    Thanks.
     
  17. slidermike

    slidermike Addicted to LI Member

    Sure,
    read the very first post in the thread you mentioned.
    https://www.snbforums.com/threads/release-382-asuswrt-merlin-382-1-is-now-available.42127/
    Merlin laid it out plain as day.
    I saw his original comment in the beta thread on the topic.
    "Other models will gradually be ported as Asus issues 382 GPL code for them.

    Asuswrt-Merlin 382.xx was started from a clean GPL release, with the Asuswrt-Merlin changes re-applied on top of it. This was made necessary due to the large amount of changes between 380 and 382. Because of this, both branches will for the time being be developed in parallel, as models will gradually be ported over from the 380 code to the newer 382 code (as Asus progressively migrates them to this new code base).

    Please don't ask for any ETA concerning other models, as I don't have any to give. First, Asus will have to release 382 GPL code for these other models before I can even begin to look into it.
    "
     
    phalkon30 and pablot like this.
  18. pablot

    pablot New Member Member

  19. ReZeon

    ReZeon New Member Member

    Just updated to Merlin and have to admit I'm loving it a lot more than the stock firmware. However I appear to be missing the "Traffic Manager" tab. Has this been removed or have I messed up somewhere?
     
    Last edited: Nov 14, 2017
  20. Ubimoo

    Ubimoo Reformed Router Member

    "Enable BWDPI" under "Tools - Other Settings" and then reboot
     
    Almighty1 and slidermike like this.
  21. ReZeon

    ReZeon New Member Member

    Thanks very much. All sorted now, much appreciated :)
     
  22. GPz1100

    GPz1100 Network Guru Member

    @XVortex,

    In the changelog you mention:

    Code:
    376.48 Beta 1 (18-Oct-2014)
    - FIXED: Re-added the USB HID kernel module needed for UPS monitoring
               (patch by ryzhov_al)
    Is this patch still in the current firmware? I'm trying to get apcupsd working but it's not seeing the UPS.

    Code:
     cat /proc/bus/usb/devices
    
    T:  Bus=02 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#=  2 Spd=12  MxCh= 0
    D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
    P:  Vendor=051d ProdID=0002 Rev= 0.90
    S:  Manufacturer=American Power Conversion
    S:  Product=Back-UPS BX1500G FW:866.L1 .D USB FW:L1
    S:  SerialNumber=3B0922X19672
    C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  2mA
    I:* If#= 0 Alt= 0 #EPs= 1 [B]Cls=03(HID  )[/B] Sub=00 Prot=00 [B]Driver=(none)[/B]
    E:  Ad=81(I) Atr=03(Int.) MxPS=   8 Ivl=100ms
     
  23. Incubus32

    Incubus32 New Member Member

    Hi!

    Just flashed my R7000 with recent Xvortex firmware, So far pretty stable, but I noticed that my Wi-fi coverage dropped. My wireless extender can't seem to find the 5ghz from the router. Any ways to improve the Wifi coverage? TX power doesn't seem to work properly, Tried bumping it but still same results. Thank you guys!
     
  24. slidermike

    slidermike Addicted to LI Member

    Try a different channel for 5Ghz. Personally I use channel 149. You should do a site survey to see whats best in your area.
     
  25. Incubus32

    Incubus32 New Member Member

    @slidermike

    Thanks for the reply man! A noob question/request :) Can you recommend me a site survey software that I can use. Thanks again!
     
  26. slidermike

    slidermike Addicted to LI Member

    The router has a built in spectrum analyzer.
    However from my android cell phone I use "wifi analyzer". Its free and suits my infrequent needs.
    Basically you want your router talking on the channels least used by nearby devices.
    Its like speaking in a room. The more voices, the harder it is to be heard clearly by others.
     
    phalkon30 likes this.
  27. Incubus32

    Incubus32 New Member Member

    Thanks got the wifi analyzer app, hmm What's the best channel bandwidth for 5ghz connection? Still my extender cant find the 5ghz connection. before I have no problem with wifi coverage using netgear's stock firmware.
     
  28. slidermike

    slidermike Addicted to LI Member

    Probably be helpful to get some screen shots of your 5ghz configuration.
     
  29. Incubus32

    Incubus32 New Member Member

  30. slidermike

    slidermike Addicted to LI Member

    For testing purposes I would do a couple of things.
    Make sure you apply your settings after each change.
    #1
    Change the wireless mode from "N/AC" to all.
    #2
    If that doesn't work, reload the router & see if that made a difference.
    #3
    Reset the router to factory defaults.

    Those choices are router specific.
    We don't know what range extender you have or how its configured.
    The issue may lay on that device. Maybe power cycle or reconfigure it.

    Lastly, which country are you in and did you make sure the router country code is correct for your location?
     
  31. Incubus32

    Incubus32 New Member Member

    @slidermike

    Thanks for the great help man, I am residing in Philippines. But I bought the router in the US (brought home by my sister) I don't have any wifi coverage problems using the stock FW but I fell inlove with the GUI and flexibility of Merlin firmware tho.
     
  32. slidermike

    slidermike Addicted to LI Member

    I would make sure the router is using the correct country code. Not all countries allow the same channels and if the wifi extender is using a different scheme then its possible the router and extender aren't talking on common channels.
    These are the US vs. PH channels allowed.
    US
    36 40 44 48 52 56 60 64 100 104 108 112 116 120 124 128 132 136 140 149 153 157 161 165
    PH
    36 40 44 48 52 56 60 64 100 104 108 112 116 120 124 128 132 136 140 149 153 157 161 165

    So they should match as you can see above. It does not appear to be a country code conflict.
     
    Stimpy88 likes this.
  33. Magister

    Magister LI Guru Member

    After years of using Tomato, I wanted to try Merlin, it is very nice and well polished, but for me, the parental scheduling is unusable...
    Imagine having 3 children, kid to pre-teen, with cellphone, ipod, laptop, tablet, xbox, wii, ds, etc. In Tomato I created group of their MAC to easily cut wifi at 10PM or whatever, when it needs change it is easy to change a number, but in Merlin there is one schedule per MAC address, meaning I would need to create something like 15 entries, and if I have to change a time because holidays or whatever, I have to change the 15 entries!
    Also there is no granularity except by hour?!? not even half-hour?!?
    For parents, Asuswrt/Merlin firmware is basically unusable :-(
     
  34. RimRider

    RimRider New Member Member

    I've searched the whole thread but can't find a definitive answer.

    Before I spunk £200 on an AC86U, has anyone successfully managed to run two VPN clients simultaneously without random LAN IPs going through one or other VPN?

    When I setup Policy Rules, apart from those devices specified to use the VPN, other non-specified LAN IPs are also being routed through it.

    There have been a few different posters who have experienced this issue, but they never received a relevant response. Hoping someone can contribute an answer to this.

    TIA.
     
  35. slidermike

    slidermike Addicted to LI Member

    Why are you posting questions about an Asus router in the R7000 thread?
    You want to go to snb forums where Merlin and the Asus router owners discuss the router and firmware.
    That's a good router from what I read.
    Good luck!
     
    Last edited: Dec 2, 2017
  36. RimRider

    RimRider New Member Member

    I have the R7000 right now, flashed with Vortex. If I can't get policy rules to work, THEN I may need to buy the Asus...
     
  37. Mezrein

    Mezrein Connected Client Member

    Hey guys, where did the parental controls features go?

    EDIT:
    Ignore me, found it.
     
    Last edited: Dec 2, 2017
  38. slidermike

    slidermike Addicted to LI Member

    Would you share your policy screen so we can see exactly how your policy is configured?
    Then also explain what other IPs are going over the vpn that should not.
    I don't recall hearing folks complain about PBR not working.
    My r7000 has been in AP mode for about a year but I used to use the PBR and it worked perfectly. I have not tried it on any of the later code so its possible something is off. Though, I would assume it to be a safe bet if its an issue for one it would be an issue for all who use PBR. Doesn't strike me as an often mentioned issue.
    Most recently the common complaint I hear about here is the "where did parental controls go?".
     
  39. slidermike

    slidermike Addicted to LI Member

    I read over on the SNB forums that Asus just released the source code for the ac68u (same hardware as the R7000 we run) so assuming Merlin puts his usual "over the top" effort into getting that merged into the new code, in theory we could see a port "fairly soon".
    Of course no time frames but the fact Asus released the source code the #1 step in moving forward.
     
  40. RimRider

    RimRider New Member Member

    Cheers, slidermike. I've already bought the Asus RT-AC86U, but the problem still exists...

    From what Rmerlin says on the other forum, what I want to do isn't even possible! Wish I'd know that before spending 200 quid on a new router!
     
  41. IngoPan

    IngoPan Serious Server Member

    Whats the easiest way to limit bandwith for the 2.4GHZ WLAN please ? I´d like to limit the whole 2.4 to 10k down and 2k up. Thanks in advance. If this doesnt work, how to limit bandwith for seperate clients (or guest wlan?) ?
     
  42. slidermike

    slidermike Addicted to LI Member

  43. juanjekla

    juanjekla Reformed Router Member

    Hi guys!! Is there an option to get the QoS!?
     
  44. David1

    David1 Connected Client Member

    Never tried this, but you can test
    https://nwgat.ninja/limit-bandwith-for-ssid-on-asuswrt-merlin/
     
  45. Almighty1

    Almighty1 Serious Server Member

    "Enable BWDPI" under "Tools - Other Settings" and then reboot
     
  46. peyton

    peyton Network Guru Member

    build-in QoS is not working great on R7000 with vortex build.
     
  47. slidermike

    slidermike Addicted to LI Member

    Just to clarify what peyton said.
    traditional QoS is actually broken in ASUS builds not just Xvortex.
    Its a long standing/ known issue with ASUS router firmware.
    The general feeling is that since ASUS offers the Trend Micro module (including adaptive QoS) they don't need to fix it.
     
  48. Liseeker

    Liseeker Reformed Router Member

    Hi Slidermike,

    First let me say you're a good forum contributor. Much appreciated.

    I used to run Vortex on my Netgear R7000 till I had to migrate to Kong's DD-WRT for more advanced features. It's where I also found your earlier posts on DD-WRT forum. Mind you, Vortex has its good points. Don't get me wrong. I sometimes visit 'old ground'. Just in case there is something new.

    But if I may. I am just wondering why you stopped contributing to DD-WRT forum. Are you using DD-WRT at all?

    Thank you and wishing you a good day.
     
  49. slidermike

    slidermike Addicted to LI Member

    Hi Liseeker.
    Thank you for the kind words.
    There are many folks who contribute to both or more forums.
    I aslo skulk around the SNB forums but post even less because I don't own an Asus router.

    That said, I do still on occasion post in the ddwrt forums.
    In fact earlier this evening I responded to a comment.
    It is true I am less "active" there now since I generally run the xVortex port on my r7000.
    I keep up on what is going on over there and the SNB forum.

    I have been running a repurposed I7 pc with pfSense as a true FW and the r7000 has been a dedicated AP for about 1 year now.
    Due to the basic functionality of the r7000 configuration as an AP there are less features I can specifically speak to now. I don't know if openvpn works on the newer firmware etc..
    :)
     
  50. akyboy

    akyboy Network Guru Member

  51. ggp759

    ggp759 New Member Member

    Hello all. I want to install this firmware on my R7000 but confused about the initial flash that i read on the first page. I downloaded the file from the link on the first page. My R7000 has stock firmware. The file i downloaded contains both chk and trx file. The very first time i flash from netgear firmware i first flash the chk and then the trx or just the trx? Thanks alot.
     
  52. Liseeker

    Liseeker Reformed Router Member

    Since you run pfSense as main router and R7000 as AP, I now understand why. I also use MikroTik in many cases because of the highly granularity and flexibility of its OS. To answer your point re OpenVPN though. R7000 on DD-WRT handles both OpenVPN server (my own created certificates and so on) and PIA client at the same time with no issue. I have been running this setup for several months. Currently on v3.0-r34015M kongac (12/09/17).

    Cheers.
     
  53. Liseeker

    Liseeker Reformed Router Member

    Use the .chk to flash Netgear's original firmware on R7000 to Vortext. After the initial .chk flashing, restart the router to ensure that it was successfully flashed to Vortex.

    Once you confirmed that it is the case, for any subsequent Vortex flash, only use the .trx. for any future Vortex version update.

    You can therefore flash it with the .trx, having done the .chk for the first time, but I don't think you need to.
     
    Makaveli likes this.
  54. slidermike

    slidermike Addicted to LI Member

    Lol,
    I was not saying I had a question about openvpn.
    I was giving an example about a feature not available in AP mode, thus I cannot speak to it these days on either ddwrt or xvortex.
     
  55. XVortex

    XVortex Networkin' Nut Member

    XWRT 380.69 is available for download.

    this is a bugfix release. it addresses security and other issues,
    also versions of some components have been updated.
     
    cybrnook, Stimpy88, Makaveli and 7 others like this.
  56. Almighty1

    Almighty1 Serious Server Member

    Updated from 380.68_4 to 380.69_0 with existing configuration without issues.
     
    XVortex and Makaveli like this.
  57. Ryan Will

    Ryan Will New Member Member

    The changelog says that it updated RT-N66U and RT-AC66U GPL to fix KRACK in repeater/bridge mode.

    Does that apply to the R7000 as well?
     
  58. slidermike

    slidermike Addicted to LI Member

    No, the AC-68u is the equal to the R7000.
     
    Ryan Will likes this.
  59. Ryan Will

    Ryan Will New Member Member

    Thanks for the quick response.
     
  60. Ubimoo

    Ubimoo Reformed Router Member

    I just updated to 380.69. Now this shows up in log:

    Code:
    deleted
    
    Edit:
    I restarted skynet, now all is working again as supposed....
     
    Last edited: Dec 12, 2017
  61. Makaveli

    Makaveli Networkin' Nut Member

    For everyone on .69 any issues with slow page rendering that has been reported in the SNB forums??

    I'm going to hold off on updating until I get more feedback.

    Currently at 62 days up time on 68_4 and everything has been running great.
     
  62. Kallac

    Kallac New Member Member

    If it's true that the Merlin AC68U version is used to create the Vortex R7000 version, then it could possible be here soon as on the Merlin Github it's stated that 382 is now supported for all AC68U editions:
     
    slidermike likes this.
  63. immetjes

    immetjes Serious Server Member

    I searched the SNB forums but this is not easy to find. Can you provide an URL to that specific topic please? Thanks!
     
  64. Makaveli

    Makaveli Networkin' Nut Member

    Last edited: Dec 13, 2017
    Almighty1 and immetjes like this.
  65. thelonelycoder

    thelonelycoder Reformed Router Member

  66. Makaveli

    Makaveli Networkin' Nut Member

    I still haven't installed Skynet yet will probably do that this weekend.

    however AMTM, AB-Solution and Pixelserv are all working error free in the .69 firmware for me.
     
  67. thelonelycoder

    thelonelycoder Reformed Router Member

    Skynet is a must have, just like AB-Solution and they work very well together.
     
    Dromandus, Makaveli and Ubimoo like this.
  68. T-Birth

    T-Birth Reformed Router Member

    Hi,

    Flashed the new v380.69

    But I cant DISABLE the Asus NAT tunnel service under Other Settings -> Tweak.
    Are there any requirements to let this option stay disabled ?

    Even after disabling it, one restart from the router and its turning itself back on.

    Any thoughts ?
    Thanks
     
  69. XVortex

    XVortex Networkin' Nut Member

    It is known issue. On the asuswrt-merlin firmware it appears too.
    I think it will be fixed in the next release.
     
    phalkon30, T-Birth and Stimpy88 like this.
  70. peyton

    peyton Network Guru Member

    I have both and works great on new release just like with the old one.
     
    Almighty1 and thelonelycoder like this.
  71. dr.bob

    dr.bob New Member Member

    Hi, tagged IPTV runs well on LAN port 3 (or LAN port 4) on my R7000. But IGMP proxy does not work on the latest firmware 380.69. Is this a bug or my bad settings? Thank you for your response.
     
  72. boochi

    boochi Serious Server Member

    It has been a while since I used this firmware on my R7000. I always went back to dd-wrt. Well I now want to go back to xwrt. However I can't. The flash from stock appears to work without any gui error, but it goes in to a continuous boot loop. I get the following text from the serial connection to the router (.jpg attached). Any ideas?
    [​IMG]
    [​IMG]
     
  73. slidermike

    slidermike Addicted to LI Member

    I am not a kernel /crash expert but it looks like the kernel panic is from an issue reading something in the JFFS partition.
    Do you have the router OC'd?
    Some folks have issues with firmware flashing while over clocked.
    Also, could be a bad firmware flash because the copy you got didn't come down clean or write to the router clean.
    If you can recover and try again it might work.

    Also, try flashing it without any thumbdrives attached if that's where your JFFS partition is.

    Again, since I have no experience recovering or kernel debugging my opinion is about as valid as a potato.
     
  74. boochi

    boochi Serious Server Member

    I am able to recover through tftp to stock or dd-wrt without error. I have tried multiple versions several times with the same result, flashing from netgear gui and tftp. Mind you it worked a year ago without error. Is there a way to clean the jffs safely and retry? Never overclocked.
     
  75. slidermike

    slidermike Addicted to LI Member

    I don't know about the JFFS cleaning. If its the nvram and the blocks are bad then its just bad blocks in nvram and there is no fix.
    If you still have the older XVortex code that you had ran before, try flashing that to the router and then do an in place upgrade to the newest code.
     
    Almighty1, phalkon30 and Makaveli like this.
  76. Liseeker

    Liseeker Reformed Router Member

    I think I can help decipher the above.

    I wondered why, at one stage, my MikroTik router does not enforce rules over local traffic prior to its entering the VPN tunnel such as access restrictions. The VPN traffic seems to bypass any relevant rules I set up earlier.

    I had not raised this question in MikroTik forum. Nevertheless, I came to the inescapable conclusion that for the integrity of a VPN connection to be trusted by users, any traffic travel on the tunnel can only be decrypted by the originator and recipient and no party in between can read it. If a local router can read the contents, it follows that any host on the local network may be able to read it too.

    This would then compromise the integrity of OpenVPN. It's my educated guess that being the reason why your OpenVPN and Access Resriction don't work together. I think the router can keep track of how many [edit: added for clarity] packets going through the VPN tunnel though.

    Good luck.
     
    Last edited: Dec 29, 2017
    phalkon30 likes this.
  77. Frank2

    Frank2 Networkin' Nut Member

    Mak,
    Have you installed Skynet yet? Do you know if we have to enable IPV6 to use Skynet?
     
  78. pp2992

    pp2992 Network Newbie Member

    They all are working flawless so far on my R7000 with Xwrt-Vortex 380.69
     
    thelonelycoder likes this.
  79. pp2992

    pp2992 Network Newbie Member

    I have IPV6 disabled and Skynet works fine.
     
  80. Frank2

    Frank2 Networkin' Nut Member

    Thanks. I just installed it myself and it works fine with IPV6 disabled. So does the Skynet just block bad IP's? Is that all it does?
     
  81. pp2992

    pp2992 Network Newbie Member

  82. thelonelycoder

    thelonelycoder Reformed Router Member

    AFAIK, Skynet does not support IPv6.
     
  83. Makaveli

    Makaveli Networkin' Nut Member

    That is the only reason I still didn't install it yet.

    I use IPv6 ISP has it enabled for almost 2 years now.
     
    Last edited: Dec 30, 2017
    thelonelycoder likes this.
  84. tekbar7522

    tekbar7522 New Member Member

    Hello, I just installed xwrt-vortex on my r7000. I am coming from DDWRT. I am now trying to use something called YAMON to track bandwidth usage.

    When my router reboots, it deletes all the files located in /var/wwwext/ (Which is also /tmp/var/wwwext/).

    Does anyone have a way of having these files not be deleted after each reboot?
     
  85. David1

    David1 Connected Client Member

    I dont use YAMON, but i do use xwrt-vortex bandwidth-usage, and store the files on a USB under /mnt/USBname/,
    which is non-volatile.
     
  86. tekbar7522

    tekbar7522 New Member Member

    Thanks David1. I do also store my files on a usb drive that are mounted under /opt/... but my issue is the web interface files are wiped out, so I am unable to see them unless I re-run the install files or manually copy over the files back into the wwwext directory.
     
  87. David1

    David1 Connected Client Member

    can you not install them on the usb drive aswell, or you could try under /jffs/

    Edit
    Forgot, you need to enable jffs under administration/system on the web gui
     
  88. tekbar7522

    tekbar7522 New Member Member

    Then how would I point the web server (on the router) to that folder? i want to be able to see the page that is hosted on the router in my web browser.
     
  89. David1

    David1 Connected Client Member

    so i had a quick look at it, not sure if i am 100% right though, installed it using manual setup, but instead of using /opt I used /mnt/USB/YAMon3/
    http://usage-monitoring.com/manualInstall.php

    option 8 allows me set web directory

    #8. Specify the path to the web directories?

    The path must start with a `/`
    - hit <enter> to accept the current value: `/tmp/www/`, or
    - type `d` for the default: `/tmp/var/wwwext/`, or
    - type your preferred value --> /mnt/USB/YAMon3/www/

    also changed option 9 because i could only access the page with the www added, (not sure y)

    #9. Specify the URL path to the reports - e.g. 192.168.20.1<path>?

    The path must start with a `/`. Do *NOT* enter the IP address!
    - hit <enter> to accept the current/default value: `/user`, or
    - type your preferred value --> /user/www

    then I created a symbolic link using

    ln -sf /mnt/USB/Yamon3/www/ /www/user/
    and then ran /mnt/USB/Yamon3/startup.sh (if not already started)

    i can access Yamon using
    http://192.168.20.1/user/www/index.html

    You will need to create a script by editing /jffs/script/init-start
    to create a symbolic link from above and also start Yamon,
    so when u reboot it automatically starts up Yamon and creates your symbolic link at startup
     
    slidermike and tekbar7522 like this.
  90. Dioden

    Dioden Networkin' Nut Member

    Hi

    I have just istalled this firmware, and dont get all choises under "General" tab, I only get :

    General

    Network Map

    Guest Network

    USB Application

    Tools


    Missing parental controll and others.

    Have tryed reset to factory, and 30-30-30 reset.

    Any ideas ?

    Regards

    Dioden
     
  91. Almighty1

    Almighty1 Serious Server Member

    "Enable BWDPI" under "Tools - Other Settings" and then reboot
     
    Dioden and Stimpy88 like this.
  92. Dioden

    Dioden Networkin' Nut Member

    Thank you
     
    Almighty1 likes this.
  93. Mezrein

    Mezrein Connected Client Member

    Hey guys, was curious to know if there is any android app available with this firmware? The original Netgear R700 had an app that allowed you to control most features of the router from any network connection, any chance of something similar for this firmware?
     
  94. slidermike

    slidermike Addicted to LI Member

    Yup the Asus router app.
     
    Almighty1 and Makaveli like this.
  95. Mezrein

    Mezrein Connected Client Member

    Ok, that was too easy.

    EDIT: How rude of me, thank you.
     
    Last edited: Dec 31, 2017
    Almighty1 and slidermike like this.
  96. tekbar7522

    tekbar7522 New Member Member

    Hi David1, thank you so much. I was able to get it working with your help.
     
  97. slidermike

    slidermike Addicted to LI Member

    thelonelycoder and Makaveli like this.
  98. Justin Trant

    Justin Trant New Member Member

    Hello,

    I have a Netgear R7000 currently running v380.69. A few months ago my VoIP phone stopped working (could hear the other party but they couldn't hear me). I put it down to an issue with the phone or SPA device and forgot about it.

    I recently switched wireless carrier to one with WiFi calling. I'm unable to get the feature to work when at home, but it works fine everywhere else (work, public WiFi etc). I have narrowed the issue down to the hardware acceleration option on the R7000. When I disable hardware acceleration, WiFi calling works immediately. When I re-enable hardware acceleration, it stops working again.

    IPSec and SIP passthrough are enabled, and I have tried toggling through every option available to no avail. I also set a port trigger for UDP 443 and 4500 which also did not help.

    It does seem that the VoIP and WiFi calling issues are related, and since the VoIP phone stopped working suddenly a few months ago, I'm thinking it's firmware related.

    Does anybody have an idea as to what I can try next? I do need hardware acceleration enabled as I have gigabit internet, and it was very difficult to find a router that supported these speeds so I'd rather not go down the road of replacing the router to get this feature working.

    Thanks in advance,
    Justin.
     
  99. slidermike

    slidermike Addicted to LI Member

    Makaveli likes this.
  100. Justin Trant

    Justin Trant New Member Member

    Hi there,

    Thanks a lot. I did try all of the suggestions on the page you linked to no avail. SIP passthrough and IPSec passthrough are both enabled.

    I thought about downgrading to 380.62.1 but can't find it on the download page or GitHub. I was also concerned about downgrading to a version that may have been affected by the WPA2 vulnerability, or is this not an issue since it's technically ASUS firmware?

    Thanks again,
    Justin.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice