1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Asuswrt-Merlin on Netgear R7000

Discussion in 'Other Firmware Projects' started by XVortex, Mar 27, 2015.

  1. barek16

    barek16 New Member Member

    Hi everyone. Im new there. I've just buy R7000 and want to instal XWRT/Asus-Merlin. Can I just made:
    1. Reset your router to factory defaults via the web interface.
    2. Flash the R7000_xxx.xx_x.chk file via the web interface.
    3. Do another factory reset via the new web interface.
    4. Reboot your router via the web interface or power cycle.
    5. Flash the R7000_xxx.xx_x.trx file via the web interface.
    6. Check new options and configure everything else.
    And enjoy New firmware ? I start to read First pages and see some region wifi issue and other troubles. That was solved right now ?
     
    Last edited: Oct 16, 2017 at 11:23 PM
  2. Almighty1

    Almighty1 Serious Server Member

    Yeah, you might want to just use the IP Address for the hostname as it should work.
     
  3. slidermike

    slidermike Networkin' Nut Member

    You are aware that WOL is a LAN function right?
    The protocol was not designed for WAN to LAN.
    I know there are "tricks" to making it work over the internet but I didn't have much luck getting it to work a couple of years ago when I was running dd-wrt or tomato.
    Good luck
     
  4. David1

    David1 Connected Client Member


    As slidermike said WOL is designed for lan, but you can try port forward to your broadcast ip eg. 192.168.0.255
    and see if that works
     
  5. Almighty1

    Almighty1 Serious Server Member

    Stimpy88 likes this.
  6. cybrnook

    cybrnook Addicted to LI Member

    Makaveli, peyton, Almighty1 and 2 others like this.
  7. David1

    David1 Connected Client Member

    So i have managed to get the home monitor working, problem was that the logs the router was sending, home monitor could not do anything with them because they werent bandwidth logs, so to enable the correct logs, need to create a script which will send the correct syslogs, for it to be permanent, add it to init-start or something
    I dont understand the script myself as i got it from
    https://www.snbforums.com/threads/monitoring-web-usage-with-asuswrt-merlin.15558/page-5
    so if someone knows how to clean it up for the use of home monitor

    ```
    #!/bin/sh

    if [ -z "$(iptables -n -L FORWARD | grep 'web_monitor')" ]; then
    modprobe ipt_webmon
    iptables -t filter -N web_monitor
    iptables -t filter -I FORWARD -o eth0 -j web_monitor
    iptables -I FORWARD -o tun12 -j web_monitor
    iptables -A web_monitor -p tcp -m webmon --max_domains 2000 --max_searches 2000
    iptables -I web_monitor -m state --state NEW -j LOG --log-level 6 --log-prefix "webmon"
    fi
    ```

    Edited
    https://github.com/amiracle/homemonitor/issues/9
    enabled firewall logs and added this to init-start
    iptables -A FORWARD -i br0 -j logaccept
     
    Last edited: Oct 10, 2017
    Almighty1 and slidermike like this.
  8. Almighty1

    Almighty1 Serious Server Member

    Upgraded from 380.68_3 to 380.68_4 without any problems yet.

    This is the change log:
    380.68_4 (4-Oct-2017)
    - CHANGED: Updated dnsmasq to 2.78 (contains a number of
    security fixes).
    - FIXED: rstats could crash at start time in some situations.
    - FIXED: QOS Scheduler would revert back to sfq after you had
    re-enabled QOS while (fq_)codel was already selected.
    - FIXED: Missing tabs on the Parental Control page.
    - FIXED: Realtek port status wouldn't auto-refresh on the Sysinfo
    page.
    - FIXED: Incorrect sort by remaining time on the DHCP Lease page.
    - FIXED: Some LAN clients couldn't be added to the TOR redirected
    client list.
     
    Last edited: Oct 10, 2017
    Makaveli and Stimpy88 like this.
  9. Leonardo MOrales

    Leonardo MOrales New Member Member

    Hello all,
    I'm facing an issue regarding "Bandwidth Limiter", it doesn't limit the band when "Enable BWDPI", with it disabled, on old hidden QoS page method it works perfectly. any thought? I didn't like to lost new QoS metrics that are awesome!
     
  10. spritty1300

    spritty1300 Network Newbie Member

    Hi,
    I am trying to overclock my R 7000 with the newest 380.68_4 Software.
    I have asked here already over a year ago and got told it wouldn't work with the vortex Software at that moment.
    Now I have read other people are running it with overclocking, so it must be possible somehow?

    I tried with run Command in the Tools section:
    nvram set clkfreq=1200,800
    nvram commit
    reboot

    It reboots but nothing happens, when i type in:
    nvram get clkfreq
    I still get 1000,800 shown in the big window.

    What are I am doing wrong?
    Would be nice if somebody can help me.
    I was running 1200 Mhz before with DD-WRT without any Problems.
    Other than that I really like the ASUS-WRT compares the DD-WRT. It's so much easier especially to use a VPN over openVPN.
     
  11. slidermike

    slidermike Networkin' Nut Member

    Try customizing your CFE.
    You should be able to set the default speed to 1200/800.
    Be careful since your telling the router to use it as default.
     
  12. Stimpy88

    Stimpy88 Network Newbie Member

    Strange that we don't get notified here of new releases these days...

    FYI version v380.68_4 is out now.
     
    Almighty1 likes this.
  13. David1

    David1 Connected Client Member

    it was, look at post #4706 from cybrnook
     
    slidermike and Almighty1 like this.
  14. piet99

    piet99 New Member Member

    my cable abbo went from 200mbs to 400 mbs, i only get speeds with 5ghz around 270 mbs.
    Running latest merlin firmware, is the router topped at 280 or should i be able to get more speed out of my R7000 ?
    the router is like 6 meters away from my pc with no obstacles inbetween.
    Would like to get around 350mbs or so.....
    Am running at 80mhz and picked a channel thats not crowded.
    Upping tx didnt do anything.
     
    Last edited: Oct 11, 2017
  15. slidermike

    slidermike Networkin' Nut Member

    piet99,
    you have left out all the specific details about the wireless client.
    Maybe the client is only able to connect/transfer at x speed.
    Just because you have a 400Mbps WAN doesn't mean any single client is capable of using it.
    Lots of things on the client side are also just as important as the router for high speeds.
    wireless card type/model, # of antenna, antenna position, drivers, driver settings, OS & its settings are some of the items that come to mind right off.
     
  16. piet99

    piet99 New Member Member

    Hi slider Mike,
    Thx for your answer.
    All clients have a ac usb adapter (dlink1200ac) or ac wireless network card and are able to reach 200mbs easily but never higher then 280 mbs.
    I am using a cat 6 cable (10mt) from my modem to my router.
    I have no clue why the ac wifi doesn't reach his full speed, am trying to optimize it for 3 days now. Maybe it's the firmware ?
     
  17. slidermike

    slidermike Networkin' Nut Member

    Have you verified with a wired client that your actually getting the full speed increase?
    Using a wired client go to dslreports.com/speedtest and see what kinds of speeds your getting.
    You can also switch firmware to stock, retest & also dd-wrt, retest.
    See if any of them get you the speed you want.
    If so, stick with that one.
    I only have 100Mbps WAN and no issue with my clients utilizing it. So I cant help you there.

    When you test, do it with no other devices on the wifi, they could skew the results.

    I get the sense you keep thinking its the firmware which I doubt but by doing the test with stock and dd-wrt you should be able to confirm or deny that theory.

    The configuration in the router could also impact how fast your connection goes so you might want review how your 5ghz is configured or if you have other functions turned on such as vpn.
     
  18. piet99

    piet99 New Member Member

    Wired to my cablemodem i get a speed of 400 mbps so thats full speed.
    I do have a vpn server running but turning it off didnt give any speed improvements.
    I guess it could be a configuration setting but if i get 200 now i wouldnt now where to look for ....
    Must be a very specific setting i guess, maybe someone has a clue where to start ?

    i cant post screens i guess, limitations of the forum.

    [​IMG]


    [​IMG]
     
  19. Skillz

    Skillz Network Guru Member

    Can I upgrade over the current Merlin setup or is a nvram clear/reconfig always recommended?
     
  20. Almighty1

    Almighty1 Serious Server Member

    Yes for now and if it doesn't work, then you do the factory settings reset.
     
  21. Stimpy88

    Stimpy88 Network Newbie Member

    Ahh, is cybrnook XVortex now then? I must have missed when that happened...
     
    aufdenschlips and Almighty1 like this.
  22. XVortex

    XVortex Networkin' Nut Member

    cybrnook is one of the most experienced XWRT users and he has the right to leave news comments, bc I do not always have do this.
     
  23. Ted Morris

    Ted Morris New Member Member

    Hey guys. Is it just me or does the latest release still have the Parental Controls, DNS filtering, QoS controls missing? I've deleted my cached pages - still no go for me.

    Just want to make sure I'm not doing something wrong...
     
    aufdenschlips likes this.
  24. Almighty1

    Almighty1 Serious Server Member

    @Ted Morris:

    "Enable BWDPI" under "Tools - Other Settings" and then reboot
     
  25. Stimpy88

    Stimpy88 Network Newbie Member

    Respectfully, I have no idea who he/she is, and it's also your prerogative how you wish to inform or not inform the supporters/users of your work.
     
    Last edited: Oct 13, 2017 at 11:13 AM
  26. atrum1

    atrum1 New Member Member

    Hello,

    My R7000 is in version 380.68_4.
    From the pc browser, I can change the stealth mode (disable all LEDs).
    On the other hand, from a browser in ios (safari or firefox, I am under ios 11), can not change the stealth mode (deactivate all LEDs). The yes or no is frozen under ios.

    Could this concern be corrected in a future version?
     
  27. slidermike

    slidermike Networkin' Nut Member

    XVortex does not really do much outside of porting this over so it runs on non-Asus routers.
    If this is a valid issue on the Asus routers & the users of the Asus routers report it in the SNB forums to Merlin then he will likely fix it.
     
    Almighty1 likes this.
  28. cybrnook

    cybrnook Addicted to LI Member

    Try CTRL+F5 on that page to clear your cache.
     
    Makaveli and slidermike like this.
  29. Almighty1

    Almighty1 Serious Server Member

  30. atrum1

    atrum1 New Member Member

    Thank you all for your reply.
    I tried to empty the cache, it does not change anything.

    For information, it is not just that frozen.
    Under ios, can not be changed in tools, other settings
    Traffic Monitoring and Miscellaneous Options
    But I can change under ios:
    TCP / IP settings
    Advanced Tweaks and Hacks
    ASUS Features
     
  31. Dries Michiels

    Dries Michiels New Member Member

    Hello guys,

    About half a year ago I flashed my EA6900 to xwrt and loved it.
    Today I also flashed my R7000 to 380.68_4.
    I noticed a small bug I think between the two firmwares (EA6900 vs R7000).

    I have an in home DNS server and my access points have their hostname registered to the ip.
    When I try to go to say for example EA6900/ in a webbrowser I can login and everything works as expected.
    However when I try to go for example to R7000/ in a webbrowser I can login but I do not get further then login screen. When I acces R7000 through ip address so lets say 192.168.1.x I can login and I do get futher to the next menus. => strange behavior no? When trying to acces my R7000 trough DNS hostname in a webbrowser I can not get further then the login screen, even though I use the same credentials as I use to acces it through IP address.


    EDIT: So I can login using the FQDN, which in this case would be R7000.lan altough I do not have that issue with my EA6900 where I do not need to append .lan to be able to proceed further than the login screen. My DHCP server adds .lan as domain prefix, so both names without .lan resolve. But with my R7000 when accessing it through R7000 I cannot proceed further then login screen. When using IP adress or R7000.lan it does work and I can login and acces the next menus.

    Any ideas?
     
    Last edited: Oct 15, 2017 at 11:46 AM
  32. cookietoaster

    cookietoaster New Member Member

    Greetings

    Is anyone else having issues connecting to the webUI via HTTPS?

    Since I upgraded my R7000 to 380.68, firefox hangs at "Performing a TLS handshake to 192.168.1.1" when I try to access the interface. It doesn't matter which browser I'm using or which SSL port is configured for the access. I tried a factory reset, because the router got upgraded trough a few firmware versions now, but to no avail.

    It's only a minor inconvenience for me but I'm wondering if anyone else Is having this issue.

    Apart from that I want to thank Merlin and Vortex for their work
     
  33. Frank2

    Frank2 Serious Server Member

    Thanks David 1. I'm reinstalling Splunk to see if that will fix the problem.
     
  34. slidermike

    slidermike Networkin' Nut Member

    I can connect via https fine on my android tablet via chrome.
     
    Makaveli likes this.
  35. cookietoaster

    cookietoaster New Member Member

    Thanks for your reply. You are right, it works fine in Chrome. Seems to be an issue with firefox (last time I checked with Chrome on desktop I had a hanging tab still open in firefox which seemed to block other requests)
     
  36. Frank2

    Frank2 Serious Server Member

    So I just upgraded from 378.56 to 380.68_3 using the GUI. It went off without a hitch and it kept all my settings, which was nice. Everything is working perfectly. I still can't send logs to my Splunk server, but I'm not sure if that's on the R7000 end or on the Splunk server end. Anyway, it was a painless (and seamless) upgrade. Thanks to XVortex (and Merlin) for making it so easy.
     
  37. TsujiriCream

    TsujiriCream New Member Member

    Hi everyone - running 380.68_4 now.

    I've been eyeing the wiki for setting up an SSID for OpenVPN at github/RMerl/asuswrt-merlin/wiki/How-to-setup-SSID-for-VPN-and-SSID-for-Regular-ISP-using-OpenVPN.

    However, my relatives in Hong Kong were only kind enough to setup a PPTP VPN server on their end. Was wondering if anyone can pitch in on some steps for me to create an SSID to use PPTP VPN.
     
  38. aufdenschlips

    aufdenschlips Connected Client Member

  39. aufdenschlips

    aufdenschlips Connected Client Member

    Stimpy88 and Almighty1 like this.
  40. Goned91

    Goned91 New Member Member

    Hi here,

    For the KRACKATTACKS, do you have a plan to update the firmware ?
     
  41. slidermike

    slidermike Networkin' Nut Member

    All patches are done by Merlin on the main fork, XVortex then ports it to us.
    He is usually pretty quick to get the port online once Merlin releases new firmware.
     
    Almighty1 and Makaveli like this.
  42. Makaveli

    Makaveli Networkin' Nut Member

    i'm starting to think this needs to be posted on the first page for the new users. Not enough people understand how this process works.

    Based on what I've read so far on this issue it seems to be more of a problem with the Client devices than the router.
     
    Almighty1 and slidermike like this.
  43. #pbcsd

    #pbcsd New Member Member

    Hmmm ... bit of a newb myself. From what I've seen almost all router manufacturers seem to be pushing out new firmware for KRACK. E.g., my Netgear R7000 has a new one here...

    [nevermind I can't post a URL yet but it's on the netgear site anyhow]

    So seems we do need to ensure our routers are protected. Regarding the post above, "All patches are done by Merlin on the main fork, XVortex then ports it to us", not sure I understand what it means. Presumably I still have to download a new firmware and install it onto my R7000 when the patch is done and download it from XVortex website?
     
  44. slidermike

    slidermike Networkin' Nut Member

    A couple of points.
    #1 The attacker has to be in close proximity to you. This makes the vulnerability less major when your in your home with your own network.
    #2 This firmware is a fork of a fork of Asus firmware.
    Merlin forks it for Asus routers.
    XVortex forks Merlins fork and tricks the software to allow use on non-Asus routers that run similar hardware such as the Netgear R7000.
    #3 XVortex forks whatever version Merlin has publicly deployed. So once Merlin fixes a flaw & posts it, XVortex forks the fork.

    Capiche?
     
    Almighty1 and Makaveli like this.
  45. #pbcsd

    #pbcsd New Member Member

    So when XVortex forks the fork, do I need to install a new firmware from their site ... not sure what "forks the fork" means. :)
     
  46. slidermike

    slidermike Networkin' Nut Member

    When XVortex posts a release/update here on the forums then yes you will have to download that new version & install it on your router.
     
    Almighty1 likes this.
  47. #pbcsd

    #pbcsd New Member Member

    Now I capiche!
     
    Almighty1 likes this.
  48. slidermike

    slidermike Networkin' Nut Member

    Makaveli and phalkon30 like this.
  49. aufdenschlips

    aufdenschlips Connected Client Member

    Which is actually worse considering all those phones, tablets and IOT devices which will never receive an update.
     
    phalkon30 likes this.
  50. slidermike

    slidermike Networkin' Nut Member

  51. Frank2

    Frank2 Serious Server Member

    Of course, my timing couldn't we worse given the day after I update out comes the KRACK Attack. Geez!
     
  52. Makaveli

    Makaveli Networkin' Nut Member

    My blackberry Keyone which runs 7.1.1 Nougat will have this patched in the Nov 5th security patch with the rest of google phones etc. However for older devices I don't think that will be anytime soon if ever.
     
  53. petrufel

    petrufel New Member Member

    Hey, fellow forum-mates, I am getting it right, that new WPA2 vulnerability is not yet fixed in xvortex? Any estimates?
     
  54. peyton

    peyton Network Guru Member

    Makaveli and slidermike like this.
  55. slidermike

    slidermike Networkin' Nut Member

    Peyton is correct, patch the clients.
     
    Makaveli likes this.
  56. slidermike

    slidermike Networkin' Nut Member

    Off topic for a moment but I have to just say...
    Reading some users comments here, on SNB forums & ddwrt forums I am amazed at the lack of reading comprehension abound.
    A series of great examples is in the 3 pages peyton posted 2 above here.
    Merlin and others have been pretty darn clear (IMO) with what is and isn't potentially impacted.
    Yet new or occasional users are repeated (and heatedly in some cases) asking the same question over and over.

    Anyway, just wanted to express my surprise.
    Back to our regularly scheduled broadcast.
     
    Makaveli likes this.
  57. myersw

    myersw Network Guru Member

    @slidermike
    Welcome to the wonderful world of forums. ;)
    What do you mean I should do some reading before complaining?
    Been doing forums like DD-WRT since 2006 and somethings never change.
    Nice that you are still there helping. I do not use the R7000.
     
    slidermike and Makaveli like this.
  58. Makaveli

    Makaveli Networkin' Nut Member

    This is the internet in general these days and especially with the youth who I believe most of them have ADD lol.

    These days its post first read the article later or just post and don't read at all.

    Then you have post from some that clearly have very little IT experience and non existent networking skills but that's just the way it goes.

    I basically pick and choose the post I read and just keep moving :)
     
    Almighty1, myersw and slidermike like this.

Share This Page