1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Asuswrt-Merlin on Netgear R7000

Discussion in 'Other Firmware Projects' started by XVortex, Mar 27, 2015.

  1. yanakis

    yanakis Reformed Router Member

    Hi. Apologies if I am bit off-topic. Is anyone here using a reliable dual wan with fail over to a 4G dongle?

    Thank you very much.
     
  2. Stimpy88

    Stimpy88 Network Newbie Member

    Take it off Auto. Set a low numbered channel.
     
  3. Indyman

    Indyman Network Newbie Member

    Thanks Makaveli - will do
     
  4. Jose C

    Jose C Reformed Router Member

    deleted.


    Sent from my iPhone using Tapatalk
     
  5. Sleepy_Eyez

    Sleepy_Eyez New Member Member

    Hi All,

    I have a bit of an issue and I've been searching endlessly with no luck of a solution.

    My ISP provides with 150 Mbps.
    Amazon FireTV forces to use Channel 36 with 40MHz to get max speed of 70 to 80Mbps. Unfortunately with this setting all my other devices can only achieve 70 to 80Mbps max.
    There are only a limited number of channels on 5GHz to connect Amazon FireTV. RADAR channels don't work and not even recognized by the box.
    Channel Bandwidth 20/40/80MHz or 20MHz or 80MHz get about 2 to 10Mbps.
    I disable beamforming but no luck.

    I have no issues with Wired connection. I recently had to move my router to optimized WiFi reception.

    Asuswrt-Merlin 380.67 firmware.

    Does anyone have a solution?

    I also posted on SNBForums


     
  6. suranx

    suranx New Member Member

    I would like to know when the R7000 add Smart Connect feature.
     
  7. Makaveli

    Makaveli Serious Server Member

    It won't.

    Smart Connect is only available on asus firmware on 3 Band routers example RT-AC3200 model which has two 5Ghz radio and a 2.4 Ghz.

    The R7000 like the AC68U are dual band routers so only one 5 Ghz antenna and a 2.4Ghz one.

    if you need this feature I believe the stock netgear firmware supports it and you would have to use that.
     
  8. harrykh

    harrykh Network Guru Member

    Hi,

    It's been awhile since I used Netgear stock firmware and I want to test if the problems I've been getting are also in the stock firmware (my phone loses internet connection intermittently).

    The thing is, one feature of Merlin that I can't live without is the ability to assign specific dns servers to specific devices. Like for the kids I point their dns to opendns (that is setup with filtering) for appletv, chromcast I point them to a dns service for region unlock purposes (like watching GoT using HBO now).

    Does the stock firmware have such function?

    Thanks!
     
  9. Almighty1

    Almighty1 Reformed Router Member

    harrykh, no idea about stock firmware but how do you do it in Merlin since I always thought you can just define DNS servers, never knew you can assign it for specific devices. Thanks!
     
  10. Frank2

    Frank2 Serious Server Member

    Thanks, Mak. Just curious, why does the router bottleneck over 300Mbps w/VPN and Windows wont bottleneck?
    Not that it really matters as I only get a measly 100Mbps, but I was curious in case the USA ever catches up to Canada ;)
     
  11. phalkon30

    phalkon30 Reformed Router Member

    Processing power. While this router has some guts, it doesn't hold a candle to a computer processor

    Sent from my Nexus 6P using Tapatalk
     
  12. phalkon30

    phalkon30 Reformed Router Member

    132 should work in the US with newer clients, but if it's on auto you never know. This router is capable of providing channels that you can't use in the US, which is why most recommend setting to something static.

    Try something between 36 and 48 on the 5ghz, it should be compatible with most client devices

    Sent from my Nexus 6P using Tapatalk
     
  13. Frank2

    Frank2 Serious Server Member

    Good Point!
     
  14. slidermike

    slidermike Networkin' Nut Member

    Besides Makaveli giving you the answer, the self-help option would be to backup your current settings and then factory reset it and then go screen cap the defaults.
    Once you get the info you want, restore your saved settings.
    5 minutes all told of effort and you don't have to depend upon anyone else to provide you the info.
    ;)
     
    Makaveli likes this.
  15. slidermike

    slidermike Networkin' Nut Member

    1) Traditional QoS is broken in Asus firmware. Never to be fixed as its part of the closed source blob from Asus.
    2) You can safely increase Tx to max. It wont make your hardware do more than it can. However if your asking if increased Tx is going to = better wireless performance then you don't understand how wireless works.
    Consider wireless similar to being in a room talking to someone. You can shout (increased Tx) but that doesn't mean the client can increase its volume in response. Also, if there are others talking in that room, even shouting at a concert wont make your words understood across the room.
    3) Doesn't seem like a question, more a statement. That said, vpn is cpu intensive. A dual core 1ghz router isn't going to give you line speed vpn. You are correct that a device with more horsepower like an old desktop/laptop configured as a router will be a massive improvement to vpn performance.
     
    phalkon30, Almighty1 and Makaveli like this.
  16. harrykh

    harrykh Network Guru Member

    Hi, you just go to Parental Controls -> DNS Filtering tab, you define up to 3 different DNS servers and just add devices to use those DNS servers.
    [​IMG]
     
    Almighty1 likes this.
  17. Almighty1

    Almighty1 Reformed Router Member

    Thanks!

    That explains why I never saw it since I don't use Parental Controls....
     
  18. puremind

    puremind New Member Member

    Hi All:

    Thanks for these efforts, this firmware is definitely the best and much better than the Netgear's versions...

    I have a Netgear R8500 and I am unsure if I can use this version or if this will become available soon for R8500.
    At the moment I am using Koolshare's 380.66_4 for R8500.

    [​IMG]

    and it is working great, however the cadence for them to update to the newer merlin versions is not the same as Vortex. There is yet no 380.67_0 version there. Plus, the support there is all in chinese and I cannot even register their forum (it asks for chinese text entry and I definitely cannot do).

    My question is: will this Vortex firmware work for R8500? Are there any plans to make this available?

    The top left icon on koolshare's firmware does refer me to Vortex's firmware page, that's why I am asking here

    [​IMG]


    Thanks!
     
  19. Makaveli

    Makaveli Serious Server Member

    Vortex's firmware only supports the R7000. And I doubt anyone on this site is running Koolshare's firmware since all of us have R7000's. You are going to have to work on your chinese.
     
    slidermike likes this.
  20. phalkon30

    phalkon30 Reformed Router Member

    Wow, updated from 378.54 (2015 Era) to the latest, can't believe how much more responsive the interface is! Between that and changing channels I can now get great signal in my garage too. Super happy, and the upgrade process was actually pretty easy

    Sent from my Nexus 6P using Tapatalk
     
  21. Makaveli

    Makaveli Serious Server Member

    Why would you stay on that firmware so long. There has been so many security fixes since 378.54 I would recommend not doing that again :)
     
    Clark Griswald and slidermike like this.
  22. phalkon30

    phalkon30 Reformed Router Member

    It was before things were locked out by Asus and I was afraid I would miss the features (that I wasn't even using...). I also travel 90 percent for work and was afraid of my wife calling me while I'm out of state because the router wasn't working from an upgrade.

    I agree though, I listen to Security Now every week, I should know better.

    Sent from my Nexus 6P using Tapatalk
     
    Makaveli likes this.
  23. Almighty1

    Almighty1 Reformed Router Member

    As stated on the official XVortex website mentioned on page 1 of this thread:
    http://xvtx.ru/xwrt/about.htm

    Xwrt-Vortex officially supports the following router models:
    which means it will only work for the routers mentioned and not anything else until you hear otherwise.

    I had a chance to try Koolshare's firmware on the R8000 and R8500, there does not seem to be a R9000 version but it seems like it does not require rebooting after saving config changes and the config changes save process is faster. The only problem is the main page which is the Network Map is only in the Chinese language and not the language you pick while everything else appears to work fine in the language that one selects. If that wasn't a issue, I would be using it on the R7000 since it has working QoS. Even though I read and write Chinese, it's just not natural for me as I am used to XVortex's interface in english.
     
    Makaveli likes this.
  24. Almighty1

    Almighty1 Reformed Router Member

    To test stability and uptime. No different than some people who have 20 year uptimes on their Linux/FreeBSD boxes.
     
  25. slidermike

    slidermike Networkin' Nut Member

    Latest build is working well for me.
    Router in AP mode.
    Thank you xVortex!
     
    Almighty1, Makaveli and XVortex like this.
  26. Makaveli

    Makaveli Serious Server Member

    Agreed Mike I think this has been the best build released for the R7000 so far.
     
    phalkon30 and Almighty1 like this.
  27. harrykh

    harrykh Network Guru Member

    Hi, can you share your config. Specifically your wireless channels and bandwidth. Going from DD-WRT, I had to use higher range channels for the antenna to use more power, and setting the bandwidth to one size made it more stable, long preamble was just better, etc.

    Do I need to worry about these things or are the defaults already optimal. I have done the basic I have set my wireless channels to use the least populated ones manually.

    Thanks!
     
  28. slidermike

    slidermike Networkin' Nut Member

    I don't know about Makaveli but I don't have an issue running my 5ghz (US) on either the low or the high channels. It is true (in the US at least) that more juice is allowed on the higher channels like 163.
    I don't need full power and also when doing a site survey I have several neighbors in the higher channels so I just set mine low like 39/43 and made sure I had good or excellent signal at the farthest away wifi point I needed it.
    I do set mine to higher channel bonding for the one client I have which can take advantage of 1300Mbps (though the throughput is much less than the connection rate).

    What I am pointing out is that with wireless, there is never one best answer for all. Things like long/short preamble are going to depend on what is happening locally. It also depends upon what "noise" is in your wifi range. The term noise implies anything competing on the same frequencies as your wifi. Cordless phones, neighbors wifi, microwaves, Bluetooth etc...

    Bottom line, I would start with the defaults as a baseline. Backup the config and then make minor adjustments from there. You can always revert back to your backup config to get back to baseline.

    Hope that helps.
     
    Almighty1 and Makaveli like this.
  29. Makaveli

    Makaveli Serious Server Member


    Agreed with everything posted above. Wireless is not a one size fits all, where one settings works great for one person maybe totally different for someone else. There is so many things with wireless that will affect it, you may have more access points around you, the type of materials in the walls, the NICs in the wireless devices etc etc. This is why all of my primary machines where consistency/performance is important are wired to my router. Only the cell phones and occasional laptop are on wifi. I would never run a primary desktop/workstation on wifi infact you couldn't pay me to do so.

    Everything is bone stock for wifi settings I already posted a few pics on page 44 from the professional tab these pics now are from general for each band.

    2.4 Ghz

    [​IMG]


    5 Ghz

    [​IMG]
     
    Almighty1 and slidermike like this.
  30. jeorainc

    jeorainc New Member Member

    Hi all..
    I would like to configure the following
    - Port 1 + guest wifi (wl0.1) as vlan10
    - machines under vlan 10 can talk to each other
    - vlan10 can access internet
    - vlan10 has its own DHCP server and DNS
    - vlan10 can't access vlan1

    I did some work but no luck... here is my progress, please help to modify.. please :(
    The DHCP part is less priority... so now shown below

    Code:
    WAN0_IFNAME=`nvram get wan0_ifname`
    
    # Add vlan 10 to WAN0
    vconfig add $WAN0_IFNAME 10
    
    # Assign port 1,8 to vlan10, with port 8 tagged
    robocfg vlan 1 ports "2 3 4 8t"
    robocfg vlan 10 ports "1 8t"
    ifconfig vlan10 up
    
    # Remove guest wlan from br0 and assign it to br1, assign gateway IP
    brctl delif br0 wl0.1
    brctl addbr br1
    brctl addif br1 vlan10 wl0.1
    ifconfig br1 192.168.10.1 netmask 255.255.255.0 #broadcast 192.168.10.255
    ifconfig br1 up
    
    iptables -I INPUT -i br1 -m state --state NEW -j ACCEPT
    iptables -I FORWARD -i br1 -o br0 -m state --state NEW -j DROP
    iptables -I FORWARD -i br0 -o br1 -m state --state NEW -j DROP
    iptables -I FORWARD 6 -i br1 -o br1 -j ACCEPT
    iptables -A FORWARD -i br1 -j ACCEPT
    iptables -D FORWARD ! -i br0 -o vlan2 -j DROP
    iptables -I FORWARD 4 -i br0 -o vlan2 -j ACCEPT
    iptables -I FORWARD 4 -i br1 -o vlan2 -j ACCEPT
    
    nvram set lan_ifname="br0"
    nvram set lan_ifnames="vlan1 eth1 eth2"
    nvram set lan1_ifname="br1"
    nvram set lan1_ifnames="wl0.1"
    
    killall eapd
    eapd
    I don't quite understand the iptables part, I just tried to copy what I have from br0 to br1,
    and I delete the "FORWARD ! -i br0 -o vlan2 -j DROP" as I guess this will deny me from accessing vlan2 via br1

    Please help:confused:
     
  31. phalkon30

    phalkon30 Reformed Router Member

    I won't quite that long post above, but I personally found stock settings to work the best for me. If you have an android, use the app wifi analyzer by farproc, find which channels are open and use them.

    I went from not having reliable signal in my garage on higher 5ghz bands to rock solid signal by finding that bands in the 40s were more open on that side of my house. The other side of my house now has less range, but I don't use that side of the yard. It takes a lot of individual experimenting at your location to find the right band

    Sent from my Nexus 6P using Tapatalk
     
  32. Patrick Walden

    Patrick Walden Network Newbie Member

    I updated from stock FW to the CHK, then the TRX, doing resets as I went along, and now my 5GHz wifi is dead. I've been trying to fix it for the past week, reading these posts, but I'm stuck. Can anyone help me out? What nvram values should I check? I tried settting region to US, it shows the US 5GHz channels, but the radio isn't broadcasting anything.
     
  33. slidermike

    slidermike Networkin' Nut Member

    Please provide screen caps of your wifi settings.
    We need to see what your 5ghz settings are set to.
     
  34. Patrick Walden

    Patrick Walden Network Newbie Member

    Thanks for the reply slider - here's my settings right now. I've tried moving 5GHz channels to low, high, it doesn't make a difference. I think it's something in nvram.. the radio isn't broadcasting, and I just went back to original FW, and now 5GHz is broken in latest netgear R7000 fw :(. I've flashed back doing the upgrade from the original release stock FW for R7000 (had upgraded from the most recent one to begin with - using the chk, then trx, used same procedure) resetting each time, nothing's changed.
    5-1.PNG 5-2.PNG
     
  35. slidermike

    slidermike Networkin' Nut Member

    Seems pretty normal.
    Try setting the channel (hard code) to something like 149.
    Also make sure to "apply" the setting.
    channel 36 is in the US code but try 149.
     
  36. Patrick Walden

    Patrick Walden Network Newbie Member

    I've ordered a new R7000, which I will make another attempt (and possibly sacrifice :| ) with if it comes to it. Money's not really an issue, I just would like to nail this down.

    Thanks again for the quick reply and help slidermike.
    I have already tried every channel in the US 5ghz spectrum - nadda :(
     
  37. slidermike

    slidermike Networkin' Nut Member

    ok, then we go back to KISS.
    All 5ghz clients NOT seeing the SSID or just some?
    Radios worked prior to upgrade? if not, possible faulty hardware.
    2.4 working? if not, verify antennas are securely in sockets.
    Change name of 5ghz SSID.
    No spaces and no _ in the SSID.
    If still not working, change country code & apply. Try EU/Germany.
    See the SSID now?
    Change country code back to US & apply.
    See the SSID now?
    If not, try setting the country code via the command line.
    Telnet/SSH into router & run these. (everything between the "" but not including the "")
    "
    #!/bin/sh
    nvram
    set wl_country_code=US
    nvram
    set wl0_country_code=US
    nvram
    set wl1_country_code=US
    nvram
    set pci/1/1/ccode=US
    nvram
    set pci/2/1/ccode=US
    nvram
    set wl_country_rev=0
    nvram
    set wl0_country_rev=0
    nvram
    set wl1_country_rev=0
    nvram
    set pci/1/1/regrev=0
    nvram
    set pci/2/1/regrev=0
    nvram
    commit && reboot
    "
    See the SSID (after the reboot)?
    If not, reset the router to default config & see if you can see the default SSID.
     
  38. Patrick Walden

    Patrick Walden Network Newbie Member

    Tried everything you mentioned - still no devices picking up a 5G band from that router. I'm a linux/router programming newb, is there a command I can run in SSH to check the 5G radio statuses etc? Again, I really appreciate your help.
     
  39. Patrick Walden

    Patrick Walden Network Newbie Member

    So I've got a brand new R7000 in hand. Is it better to install XVortex/Merlin from a certain build fw? I used the latest FW on my last one, and it killed the 5GHz band. Hoping it was the hardware but I figured I'd ask before I proceed.
     
  40. slidermike

    slidermike Networkin' Nut Member

    Pat, what you're describing does not sound like a common problem. There are many people who run this firmware. That issue with a 5 gigahertz disappearing is not common. I would run the latest greatest firmware.

    Normally when devices don't see the ssid, it is because the country code is off for the devices. Using channels they can't see.
     
  41. Patrick Walden

    Patrick Walden Network Newbie Member

    So in my case, it'd make no sense for the 2.4 to work and the 5 to not.. I also flashed back to stock and 5Ghz is broken in there too :|

    I have a new one w/ 30 day return policy from amazon, so I'mma get to work on that one - if worst comes to worst, I can just get a new one.

    Thank you good sir for all the help.
     
  42. slidermike

    slidermike Networkin' Nut Member

    Sounds like faulty hardware if the radio still didn't work on two different firmware makers.
    The new router should work fine on the Asus firmware.

    Good luck.
     
    phalkon30 likes this.
  43. Patrick Walden

    Patrick Walden Network Newbie Member

    Up and running on XVortex/Merlin FW - both 2.4Ghz and 5 Ghz bands w/ the new R7000! I have no idea what happened w/ the other one.. brand new.. 5ghz was working in stock FW, then stopped immediately after I flashed it. Faulty hardware indeed, just awful timing!
     
  44. gxcare

    gxcare New Member Member

    I am using 380.67 and I just tried to switch off WPS. It is disabled, but for some reason the wireless AP names for both 2.4 and 5 GHz are reset to NETGEAR without password (open network). I had to reconfigure them with AP names and security. Guest networks were unaffected.
    Is this a bug specific to R7000 or does it exist on the Merlin release?
     
  45. Almighty1

    Almighty1 Reformed Router Member

    I turned off WPS using XVortex and the SSIDs are correct and didn't change.
     
    Makaveli likes this.
  46. W. Bijlsma

    W. Bijlsma Network Newbie Member

    Patrick, I ran into the same issue with my Samsung S7 phone. Other devices were seeing the 5GHz OK, the S7 did not. Changing the 5GHz control channel from auto to 36 fixed it. It seems to be a common problem with Samsung phones.
     
  47. Patrick Walden

    Patrick Walden Network Newbie Member

    I tried every single channel up and down the 5GHz spectrum and it still wouldn't work :( Somehow, the 5Ghz radio kicked the bucket the exact moment I flashed it. It was working in stock FW before that too - I tried going back to stock when it failed on Xvortex/Merlin, and low and behold, 5Ghz had stopped working in stock FW too.

    I got another new R7000 since then, and it flashed fine, been almost a week now and everything is still working great. Just bad luck w/ the first one I'm guessing.
     
    Almighty1 likes this.
  48. Patrick Walden

    Patrick Walden Network Newbie Member

    I just did the same - ssid's are unchanged w/ mine as well.
     
    Almighty1 likes this.
  49. gxcare

    gxcare New Member Member

    Probably then it was caused by the fact that I played with the other controls on the page before switching it off, mainly the Reset button. Does this reset all the connection details? I was thinking that it affects only the WPS established ones.
     
  50. Patrick Walden

    Patrick Walden Network Newbie Member

    I'm not sure gxcare - I've hit the button before, but it was on my last fubared R7000 - pretty sure it didn't reset everything to defaults. I'll try w/ my new one in a bit after an nvram backup - I'm finally having time today to get my vpns/adblock setup.. which leads me to ask a question of my own:

    Does anyone know (and is willing to help this newb out) how I can set certain devices- ideally by MAC address- to always bypass a VPN connection even if a connection is established on any of the 5 openvpn clients? Thank you in advance to anyone who can help.

    And one for Xvortex - do you have a BTC address for donations? I've got some btc with your name on it :)
     
  51. Almighty1

    Almighty1 Reformed Router Member

    gxcare, where exactly is the reset button you are referring to as there is no reset button option under Wireless -> WPS.
     
  52. gxcare

    gxcare New Member Member

    The Reset button in the "Configured" option:

    Cattura.PNG

    Just tested again, it is hitting that reset button that resets the AP name to "NETGEAR" and its security details leaving it open. I am not sure that it is intended to work in that way, at least it is quite confusing as doesn't seem to be related to WPS.
     
    Last edited: Aug 19, 2017 at 2:27 PM
  53. Almighty1

    Almighty1 Reformed Router Member

    gxcare and Makaveli like this.

Share This Page