1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Asuswrt-Merlin on Netgear R7000

Discussion in 'Other Firmware Projects' started by XVortex, Mar 27, 2015.

  1. rok999

    rok999 New Member Member

    Ipv4 for speed test result. I need to find a reliable ipv6 test site as the DSLR test doesn't like me very much. I get 500/850 there.

    AT&T just went dual stack within the last month or so. It should be available nearly a everywhere as they recently pushed new firmware to most of the current RGs. This doesn't affect me as I'm connected to the ont via a vlan capable switch.

    With CTF enabled, there is hardly any cpu usage even at full bore 900+ mbs

    Edit: Using Comcast's server in Katy Texas I get the following:


    Bottom line is it is fairly inconsistent
    Last edited: Jun 16, 2017
    Makaveli likes this.
  2. peyton

    peyton Network Guru Member

    It's strange because the picture said 380.66_4 and xvortex did not make it.
  3. Almighty1

    Almighty1 Serious Server Member

    Wonder if 380.66_4 is just XWRT 380.66_2 modified.
  4. Makaveli

    Makaveli Networkin' Nut Member

    Guess that will depends on if "koolshare" is doing his own ports from merlin's firmware or just modify's vertex's port.
    Last edited: Jun 16, 2017
  5. Almighty1

    Almighty1 Serious Server Member

    Good question but the screenshot in post #4284 does show Vortex so one would assume he modified Vortex's port unless Vortex shared with him what needs to be done to port it.
  6. rok999

    rok999 New Member Member

    Well the "official" Asus-Merlin is on version 380.66_4

    380.66_4 (26-May-2017)
      - CHANGED: Updated dropbear to 2017.75
      - FIXED: Security issue CVE-2017-7494 in Samba.
  7. cybrnook

    cybrnook Addicted to LI Member

    It's XVortex's port base. Xvortex already explained a long time back that all the QoS features (Trend Micro Engine) is still in the build provided here. He has just had to disable the ability to use it, that's why you can't see it. It's too far integrated into the Kernel/Firmware itself to just be ripped out.

    What Koolshare is doing is just re-enabling your ability to see / influence it, even though XVortex does not, as that started issues with Merlin and Asus, since it's licensed property of Asus to be run only on Asus hardware.

    This is exactly the type of activity that is causing Asus to start blackbox closed sourcing everything now.
  8. Almighty1

    Almighty1 Serious Server Member

    Interesting. I never knew XVortex released the source code for someone to just use it and modify it. I do wonder though, for those who use RMerlin on ASUS hardware, is the QoS features (Trend Micro Engine) actually enabled and available or is it only enabled in original ASUS OEM firmware? As far as Koolshare, does he even have a website and from what I gather, is his firmware going to have a interface in chinese only or does it support other languages as well?
  9. Makaveli

    Makaveli Networkin' Nut Member

    I don't think vertex released his source.

    And the QOS features are enabled in merlin's firmware.

    The firmware already supports many languages I don't think it requires a lot of work in the GUI.
    Almighty1 and slidermike like this.
  10. slidermike

    slidermike Networkin' Nut Member

    Makaveli is correct, xvortex did not release his code.
    It's caused some folks heart burn.
    Makaveli is spot on with his entire post.
    Merlin only releases for genuine Asus routers and it's nearly stock firmware.

    Standard qos is broken in Asus firmware but the trend micro qos works.
    Not for us Netgear users of xvortex since the trend micro is disabled due to possible violations for xvortex.
    Almighty1 likes this.
  11. Almighty1

    Almighty1 Serious Server Member

    Thanks Makaveli and slidermike for confirming since I remember many were asking for XVortex to release his code but it was never released so wonder how Koolshare can mention Vortex if XVortex never released his code. I know RMerlin is for genuine ASUS routers only but I somehow mistaken that ASUS was restricting the Trend Micro to their own firmware only which means even RMerlin doesn't have it enable for genuine ASUS routers. That explains why QoS is broken in XWRT as when I enabled QoS, the Amazon Echo would not be able to connect to the router.
  12. cybrnook

    cybrnook Addicted to LI Member

    Just because he doesn't freely share his fork of asus merlin in the OP link, doesn't mean he doesn't have it in an online repo (like bitbucket :rolleyes: ). If you think about, how else is he going to continually track and merge Merlins changes into his fork, one by one by hand? .....
    Almighty1 likes this.
  13. Almighty1

    Almighty1 Serious Server Member

    LOL, good points but since if he isn't freely sharing it, he would probably keep it well hidden since he can always continually track it using some other method that only he has access to.
  14. cybrnook

    cybrnook Addicted to LI Member

    And he does. It's only shared with a few individuals, likely koolshare being one.
    Almighty1 likes this.
  15. peyton

    peyton Network Guru Member

    What does that firmware got in addition of xvortex's one (except trend enabled) ?
  16. Nitin Vaid

    Nitin Vaid Connected Client Member

    There is another port of Asus Merlin For our Routers?"
    for R7000 Too? where is it and whats the advantages over this firmware

    Its been a long time no update:(
  17. Makaveli

    Makaveli Networkin' Nut Member

    Google is your friend!

    You will have to try it I doubt anyone on this site is running it therefore won't be able to provide any feedback. Plus this isn't really the place for it, this thread is for Vortex's port.
    Last edited: Jun 20, 2017
  18. SpideRMaN

    SpideRMaN Connected Client Member

    Hi All, (newbie here)

    Does vortex firmware accept CIDR format in rules (ovpn)

    I am trying to create a rule that blocks internet access to all devices in lan if vpn is dropped so in rules for routing I am trying to put as source ip, as destination and VPN in iFace but it's not accepting the CIDR. an error pops up saying I can use CIDR format.

    what am I doing wrong ?

  19. Almighty1

    Almighty1 Serious Server Member

    I have no idea if XVortex accepts CIDR format in rules but your issue is the CIDR blocks has a range of 0-32, 150 is not a valid size for a CIDR block as remember ipv4 is 32 bit.

    Makaveli and cybrnook like this.
  20. SpideRMaN

    SpideRMaN Connected Client Member

    Thank you very much!
    Almighty1 likes this.
  21. Jan Reinhoud

    Jan Reinhoud New Member Member

    Using 380.66 2 i still have problems with the huawei (e392 u-12) dongle on my R7000.
    Losing connection at least 10 times in 5 minutes.
    This is what i could find in the log:

    Aug  1 02:00:52 kernel: DROP IN=usb0 OUT= MAC= SRC= DST= LEN=51 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5355 DPT=5355 LEN=31
    Aug  1 02:00:52 kernel: DROP IN=usb0 OUT= MAC= SRC= DST= LEN=72 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5355 DPT=5355 LEN=52
    Aug  1 02:00:52 kernel: DROP IN=usb0 OUT= MAC= SRC= DST= LEN=56 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5355 DPT=5355 LEN=36
    Aug  1 02:00:52 kernel: DROP IN=usb0 OUT= MAC= SRC= DST= LEN=62 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5355 DPT=5355 LEN=42 
    I hope you can help me, thanks in advance
  22. Almighty1

    Almighty1 Serious Server Member

    A few words to add, just remember the netmask is the important part so a CIDR/24 is basically known as a Class C or a netmask so depending how big or small you want the IP address space is, remember that you usually will lose 3 IP's as one is for the network, one is for the gateway and one is for the broadcast.
    Last edited: Jun 24, 2017
  23. SpideRMaN

    SpideRMaN Connected Client Member

    Thanks a lot, infact i created a policy route (strict) to pass all devices to vpn using the /24 then if i want one of my devices to bypass the vpn i put the ip and an iface to wan (wan is processed before vpn)
    Almighty1 likes this.
  24. potatosalad

    potatosalad Network Newbie Member

    Thank you XVortex for this firmware for our R7000 routers! I am almost 100% satisfied with it. I LOVE that I can use the Asus Router App on my iPhone with it, Tomato lacked any app support.

    One thing I am having a problem with that I want to see if anyone can help me with is that I setup a 3G modem as the WAN connection. Internet works fine on all devices.

    The problem is that my routers Internet activity light is amber instead of white like everything else.

    I remember when I first got the 3G modem setup(which was very tedious) that it needed to change the routers ip address because of conflicts. Afterwards I am getting this amber light.

    I am using a Velocity Prepaid AT&T hotspot.

    The router gui says Internet status: Connected.

    Also, I dont know where I can add manual DNS servers like Googles to the asus router in the GUI. It normally is under WAN but once you have 3G modem setup there is no place for custom DNS servers.
  25. Almighty1

    Almighty1 Serious Server Member

  26. potatosalad

    potatosalad Network Newbie Member

    I am pulling my hair out trying to get a new Unite Explore hotspot to work via USB tether with the R7000. The funny thing is, when I just swapped the Velocity with the Unite Explore it worked right away.

    But when I had to reset the router because for some reason my router login reverted to admin/admin, setting up the hotspot is an exercise in frustration.

    Every single time I go through setting up the Merlin router setup, it always has Dual Wan on and Connection set to Wan.

    When I change it to USB it has to restart the router. This takes forever. Afterwards, it says IP conflict. I let it change the router ip and again it has to restart the router which is understandable. Takes forever to restart as always.

    Then when I go to the router merlin GUI it wants me to run setup again!

    Ive gone through the same process countless times, nothing changes.

    Ive tried enabling USB modem manually. Still doesnt do anything but restart router and eventually I have to run setup again!

    The other frustrating thing is that it keeps resetting to router login of admin/admin when I am changing Dual Wan or changing IP conflict or anything that restarts the router and brings me to the eventual network setup.

    So forget the problem I was having with the amber light. This is my current situation :(
  27. slidermike

    slidermike Networkin' Nut Member

    Sounds like a possible browser cache issue.
    Try a different browser to configure the router.

    Also, be sure to hit save in the GUI if there is an option.
    Makaveli likes this.
  28. potatosalad

    potatosalad Network Newbie Member

    Alright so a browser cache clear fixed it from resetting router login to admin/admin.

    But I ran through setup > picked 3G Modem in setup > changed it to Manual so I can change APN to broadband since Im using an AT&T Unite Explore > Setup Wifi > it restarts router.

    No internet connection. Wan is set to Dual. So I change from Dual to USB. Router restarts.

    Again, wifi has been reset, login to router and again its asking to setup all over again.

    It resets the router every single time I change Dual WAN to Off and set it to USB.

    Im going crazy.
  29. potatosalad

    potatosalad Network Newbie Member

    And if I go through all of that, it still says there is an IP Conflict. I let it change the ip and every single time it resets the router to factory defaults again and I have to go through setup again.
  30. potatosalad

    potatosalad Network Newbie Member

    If I let it stay at Dual WAN.

    The USB Modem connection set to primary.

    It says Primary connection is Disconnected and the WAN IP is

    Im thinking that means its not getting a connection to the 3g modem(Unite Explore)

    Also, if I set the APN to Automatic. I have to set Location to USA. Then I set ISP to AT&T.

    If I do this, the Dial Number changes to *99***1# instead of *99# which is what was working for the AT&T ZTE Mobley I use to have.

    If I save settings with that, it restarts router.

    Then I go back to the 3G Modem settings and the ISP has changed to Telecom Italia Mobile and the APN changed to proxy.

    So im guessing it couldnt connect using the settings I gave it and it reverted to the default selection.
  31. Jan Reinhoud

    Jan Reinhoud New Member Member

    Maybe same problem as me?

  32. Jan Reinhoud

    Jan Reinhoud New Member Member

    and this

  33. Mezrein

    Mezrein Network Newbie Member

    Hey guys, hopefully not a double question, there are a lot of pages here but had a question regarding accessing my wifi.
    Currently, my wifi has guest turned off, and everyone just needs to enter my wifi passcode to use my internet. Is it possible to make it so after someone enters the code, the router generates an email to me stating that someone is attempting to use my wifi and then prompt me to allow that mac address or to deny it? So from the user side, it would show that it connected successfully to the wifi, but would not allow outbound traffic until I approved it. Not sure if that makes sense or is even possible but wanted to ask. I've been having situations where my children are bringing home devices and joining them without asking to get around parental controls. Yes I know I could just change it and make it so they have to get it from me, but I'd rather catch them trying to sneak it in.
  34. slidermike

    slidermike Networkin' Nut Member

    Not natively in the gui no.
    Maybe someone else has a better answer or alternative solution.
  35. Makaveli

    Makaveli Networkin' Nut Member

    I think you maybe able to script the email part not sure about it prompting you to accept or deny.

    Why don't you just lock down the amount of available IP's and just use MAC Address filtering.

    or you would need to spend money on enterprise level gear.

    If your children are smart enough to be spoofing mac's addresses etc then the battle is already lost.
    phalkon30 likes this.
  36. Mezrein

    Mezrein Network Newbie Member

    lol amen to that. Was just reading up on mac address filtering trying to remember if I knew how it worked since part of me remembered something about it being easy to spoof. That may be the way I have to go. ultimately, reason I wanted to try and get something through an email approval is so I can be anywhere, including camping and just click accept. Im hopeful I can get the netgear r7000 android app working on my phone in conjunction with the merlin os so I could accept mac addresses that way.
  37. SpideRMaN

    SpideRMaN Connected Client Member

    How can i check tx power (2.4ghz) from ssh, am trying nvram get wl0_TxPower, also tried wl, wl1 but am getting no reply

    Please help
  38. Makaveli

    Makaveli Networkin' Nut Member

    The Asus Router app would allow you to enable or block internet access I think per device while mobile. However this would be after they already connected but maybe good enough.
  39. SpideRMaN

    SpideRMaN Connected Client Member

    Ok, to answer myself in my last post, it is wl -i eth1 txpwr1

    Q: does the slider at the bottom of the page to set txpower in wireless > professional work?

    If i set it to 1‰ i get 1496mw and if i set it to 100‰ i get 1496mw
  40. slidermike

    slidermike Networkin' Nut Member

    I found this from another thread about AsusMerlin firmware.
    See if you get different results.
    Also, remember that Tx power is limited by several factors including the country code/channel & hardware.

    ### To CHECK your current transmit power, each line entered will result in answer.
    nvram get wl_TxPower
    nvram get wl0_TxPower
    nvram get wl1_TxPower

    Almighty1 and Makaveli like this.
  41. juanjekla

    juanjekla Connected Client Member

    Hi. I recently purchased a netgear R7000 with asuswrt merlin firmware. When I get ready to flash original firmware tells me that the file is corrupt, after a few minutes my router was left in brick. No response to ping or reset button or anything like that. I would like to be helped to revive my router would appreciate it very much.
  42. slidermike

    slidermike Networkin' Nut Member

    If I understand you, it sounds like you purchased a router with AsusMerlin firmware on it.
    Then you chose to install the stock firmware on it.
    Did you read the 1st post in this thread explaining how to go from stock to XVortex and back?

    Verify that the file your trying to upgrade with, make sure your not pointing at the .zip file.
    Don't laugh, its happened before to some.

    There is a recovery process for AsusMerlin firmware; that should be the process used if your router is on XVortex firmware.
  43. juanjekla

    juanjekla Connected Client Member

    I understand, but the problem that the router does not respond to ping I can not flash through tfpt, nor can I access via web or anything. Can you tell me the recovery process for AsusMerlin firmware?

    Unfortunately I saw it late as returning to firmware stock.

    PD:As I read I can recover my router via serial port, is it correct?
    Last edited: Jun 28, 2017
  44. potatosalad

    potatosalad Network Newbie Member

  45. juanjekla

    juanjekla Connected Client Member

    No one can help me in my case?
  46. jianlin3062

    jianlin3062 Network Newbie Member

    Web access
    Transition firmware

    1, from merlin to original firmware

    merlin======Mel-R7000-back to ofw.trx ===== R7000-V1.0.4.30_1.1.67.chk

    Transition firmware
    original firmware to merlin firmware

    original firmware=====R7000_378.52_2.chk ===== R7000_380.66_4, X7.5-610.trx


    Unable to open webpage

    TTL flash brush machine

    Last edited: Jun 29, 2017
  47. slidermike

    slidermike Networkin' Nut Member

  48. rarepupper

    rarepupper Network Newbie Member

    Just joined the forums so big shout out to all!

    Have a couple of questions to ask:
    Followed the guide to install asuswrt-merlin from first page on this thread.
    It all went smooth, however, inside the zip file there are 2 files: .chk and .trx

    If I understand it correctly, the .chk file is used to flash the firmware in, so I used that.
    Merlin firmware is running and it's also the latest version.
    Now, do I still have to flash the other .trx file as well afterwards?

    Since I'm new to this firmware, what can I do to have my router run in optimal condition?
    Aka: good speeds, range, wifi, etc? Any settings I should change?

    And lastly, how do I know I have a CFE firmware installed and if I do, is there a way
    to revert back to the stock Netgear firmware?

    Any help would be appreciated it. Thanks!
  49. slidermike

    slidermike Networkin' Nut Member

    Once on xvortex firmware, any upgrade/downgrade will use the .trx
    If you didn't put a custom CFE in the router then you don't have to wonder.
    Makaveli likes this.
  50. rarepupper

    rarepupper Network Newbie Member

    thanks for the reply slidermike, appreciate it.
    read somewhere in this thread that having a CFE prevents you from going back to stock firmware?
    is that correct? that's why I wanted to know if I had one installed or not...
  51. pablot

    pablot New Member Member

    Hi, I've been fighting with this for a couple of days.
    I have a pfSense router with a VLAN4 defined on the LAN interface tagged with id "4". That port is connected to port 1 on the router. My goal is to have a wlan on vlan4.

    This is how I have configured it:

    robocfg vlan 4 ports "1t 8t"
    vconfig add eth0 4
    ifconfig vlan4 up
    brctl addbr br1
    brctl delif br0 wl0.1
    brctl delif br0 wl1.1
    brctl addif br1 vlan4
    brctl addif br1 wl0.1
    brctl addif br1 wl1.1
    ifconfig br1 up
    nvram set lan_ifnames="vlan1 eth1 eth2"
    nvram set lan_ifname="br0"
    nvram set lan1_ifnames="vlan4 wl0.1 wl1.1"
    nvram set lan1_ifname="br1"
    nvram commit
    killall eapd
    Port 1 is tagged because it is also used on VLAN3 (another VLAN defined in pfSense and on the phisical LAN interface).

    This is the output of "robocfg show"

    Switch: enabled
    Port 0:   DOWN enabled stp: none vlan: 2 jumbo: off mac: 00:00:00:00:00:00
    Port 1:  100FD enabled stp: none vlan: 1 jumbo: off mac: 52:54:00:0a:74:e6
    Port 2:   DOWN enabled stp: none vlan: 1 jumbo: off mac: 00:00:00:00:00:00
    Port 3:   DOWN enabled stp: none vlan: 1 jumbo: off mac: 00:00:00:00:00:00
    Port 4: 1000FD enabled stp: none vlan: 1 jumbo: off mac: a0:f3:c1:f8:6f:b0
    Port 8: 1000FD enabled stp: none vlan: 1 jumbo: off mac: 78:0c:b8:37:58:61
    VLANs: BCM5301x enabled mac_check mac_hash
       1: vlan1: 1 2 3 4 8t
       2: vlan2: 0 8t
       3: vlan3: 1t 4t 8t
       4: vlan4: 1t 8t
    1045: vlan1045: 0t 3 4t 8u
    1046: vlan1046: 0 1 2 3 4 5 7t
    1047: vlan1047: 0t 2t 4 5t 7
    1099: vlan1099: 0t 4 5t 7t
    1100: vlan1100: 2 3 7 8t
    1101: vlan1101: 0t 1 3t 7
    1102: vlan1102: 0 1 2t 3t 5 7t
    1103: vlan1103: 0 1 8t
    And this is the output from "brctl show"

    bridge name     bridge id               STP enabled     interfaces
    br0             8000.c40415238d25       yes             vlan1
    br1             8000.022215a50305       no              vlan4
    With this setup when I try to connect from a wifi device to the guest SSID (defined on the XWRT gui), I've get stucked at the point when it's trying to get the IP address. So, I can pass the authentication point successfully (tried both open and wpa2 with same results) and just keeps saying that the AP has no internet access.

    pfSense shows that it has assigned the IP to the device, in this case a mobile phone, but the phone does not show the assigned IP, it just shows "some IP" totally different from the one it must be assigned by the DHCP pool on the pfSense box.

    On the pfSense box I have VLAN3 working with a DHCP for VLAN3 and also VLAN4 defined the same as VLAN3 (just with different ID tag) and also a DHCP defined for VLAN4 with different ip address ranges (VLAN3 and VLAN4

    I also have flushed both iptables and ebtables rules so nothing can block the traffic, but it still don't work.

    admin@Nighthawk:/jffs/scripts# iptables -L
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
    Chain logaccept (0 references)
    target     prot opt source               destination
    Chain logdrop (0 references)
    target     prot opt source               destination
    admin@Nighthawk:/jffs/scripts# ebtables -L
    Bridge table: filter
    Bridge chain: INPUT, entries: 0, policy: ACCEPT
    Bridge chain: FORWARD, entries: 0, policy: ACCEPT
    Bridge chain: OUTPUT, entries: 0, policy: ACCEPT
    Anyone willing to troubleshoot this to help me?

  52. phalkon30

    phalkon30 Reformed Router Member

    I would highly recommend NOT enabling remote access to change settings on your router. This is a recipe for getting owned remotely through an exploit (unless I misunderstood what you're trying to do)

    Only safe way would be log in through a VPN to your network and effectively change it from within

    Sent from my Nexus 6P using Tapatalk
    Makaveli likes this.
  53. Makaveli

    Makaveli Networkin' Nut Member

    You are correct using those app do require you to open up remote access to the router.

    That is why I only use them at home when on wifi.

    If I need to remote I would use your method which is far more secure.

    Some people enabled remote access in the SNB forums just to look in the system log to see someone had access. They thought they had a super strong password.....
    phalkon30 likes this.
  54. Almighty1

    Almighty1 Serious Server Member

    The speedtest sites do not give as accurate results as the app in Windows store or the Apple App Store.
  55. SGxTOKEN

    SGxTOKEN New Member Member

    just spent the last ten hours trying to decide tomatoe ddwrt Asuswrt. If tomatoe then shibby,advanced.or tomatoe. ddwrt is pretty straight forward. then I came across this 2 year long post in dev mode blog. Asuswrt Merlin had the options I was after I can get past the few minor hiccups especially since I don't care if this r7000 shoots out green amber red lights I did see I dsl ISP drop that got my attention but before I finished the article I saw you had already fixed it. I don't want to brick my router because I cant replace it straight away and the kids need it for gaming(em me to:)) thank you in advance for making this lackluster unsupported well ,Netgear support is on the level of my ISP. Meaning that if unplugging it and counting to 3 don't fix it try it again. Only problem is I'm still not clear on the process.1) factory reset 2) flash .chk 3).trx file 4)save upload reboot follow wizard then repeat step reboot if problem......if I get all these features and the ability to actually use the router I thought I was buying,and not what was really in the box I paid for.Netgear owes you money because if I didn't find this open source it was going to ebay to the first bidder. I will be going to the resource page and dropping a like every time I download your builds just wish I had more to give. Oh seriously thank you for this Ive learned a lot and will clearly be learning more.
  56. Shearer

    Shearer New Member Member

    I have been running xwrt-merlin on a Netgear R7000 with pretty good results for a few months now.
    I recently became interested in Wireguard as a VPN protocol, but couldn't find any Wireguard-related information for xwrt-merlin (quite a bit for OpenWRT though).

    Anyone having any experience with setting up a Wireguard client on the aforementioned configuration (R7000 + xwrt-vortex 380.66_2)? In my understanding, Wireguard requires a 3.x+ kernel, while xwrt is 2.6 - so some extra work may be required, but the question is how much of it. :)
    Last edited: Jul 9, 2017
  57. rarepupper

    rarepupper Network Newbie Member

    I tried doing this though. Enabled SSH on the router but still gave me a "connection not allowed" from my other machine.
    Do I have to open up a port or something?
  58. juanjekla

    juanjekla Connected Client Member

    Hello, I would need a help to make the band 5ghz work with the latest version in R7000, I am new in this case!!!
  59. slidermike

    slidermike Networkin' Nut Member

    Please provide more precise detail on what you see, what you want to see and other important info such as the country code & channels your using.
    Screen caps are good visual aids too.
  60. juanjekla

    juanjekla Connected Client Member

    The band 5ghz is activated and I do not get on the devices for their connection, I only available the 2.4ghz band.

    Where can I look at the country code?
  61. Stimpy88

    Stimpy88 Connected Client Member

    Try selecting a lower numbered channel.
  62. juanjekla

    juanjekla Connected Client Member

    [QUOTE = "Stimpy88, post: 289357, member: 60933"] Intente seleccionar un canal numerado inferior. [/ QUOTE]

    Thank you very much for your help. Runs perfectly
    Stimpy88 likes this.
  63. wvdang

    wvdang New Member Member

    I just picked up an R7000 and I'm about to flash XWRT-VORTEX 380.66_2. I want to make sure I got this right about reverting back to stock in the event I'm not happy with XWRT-VORTEX. I simply flash v1.0.3.80_1.1.38 provided on the first page then upgrade to NETGEAR's official V1.0.7.6_1.1.99 firmware (my R7000's current firmware). Is that correct?
  64. Liseeker

    Liseeker Connected Client Member

    Please. Should be added.
  65. Mikkaat

    Mikkaat New Member Member

    Hi Everyone,

    Im new here and have thoroughly enjoyed the read of this post so far. I have one question i would appreciate somebody answering before i update my r7000 with XVortex. Does XVortext allow the user to update the NAT Session timeout value?

    My issues is that i have a Harmony Hub which drops off the internet after about 3-4 hours after rebooting the router). I am using the stock firmware on my r7000 and every time after a reboot, the Harmony Hub will allow me to connect my phone to it while its wireless is switched off (Harmony Cloud), but then after about 4 hours, i cannot connect any more unless i reboot the router. I have tried using a N300 Netcomm which did not drop the connection at all (even after 3-4 hours..)

    Thanks in advance for your help.
  66. Almighty1

    Almighty1 Serious Server Member

    To get to XWRT-VORTEX, you would:

    1. Reset your router to factory defaults via the web interface
    2. Flash the R7000_xxx.xx_x.chk file via the web interface.
    3. Do another factory reset via the new web interface.
    4. Configure everything else.

    To go back to stock aka NETGEAR's own firmware after it is currently running XWRT-VORTEX, you would flash the
    "back to stock" firmware (v1.0.3.80_1.1.38).
  67. Almighty1

    Almighty1 Serious Server Member

    When you mean NAT Session timeout value, don't you mean the DHCP Lease time? The default is 86400 seconds so if you want it for 3-4 hours, then that would basically be 10800-14400 seconds. The issue may be the stock firmware itself and the problem may be non-existent on the XWRT firmware since XWRT basically would make the hardware similar to a ASUS router so if it doesn't happen on ASUS, it won't happen with a XWRT R7000 either. Only way you will know is to try it. Did you update the firmware on the Harmony Hub and is Logitech aware of the issue since they can probably fix it in firmware.
  68. rarepupper

    rarepupper Network Newbie Member

    Does Asusxwrt-Merlin have an "auto-logout" setting?
    Feel that if you don't physically log out of the router page someone could potentially modify its settings if left unattended.
    I know some routers have that feature implemented but wasn't sure about Merlin though.
  69. Makaveli

    Makaveli Networkin' Nut Member

    Yes its on the administration tab.

    Under Web Interface.
  70. T-Birth

    T-Birth Reformed Router Member


    Im using the R7000 with Xvortex (380.63_2) for long time now in combination with AB-Solutions.
    Everything works fine but on my Mac and my iPhone, i get this nasty certificate Error's on google or Youtube etc.

    “Safari can’t verify the identity of the website “static.ak.google.com”

    The certificate for this website is invalid. You might be connecting to a website that is pretending to be “static.ak.google.com”, which could put your confidential information at risk. Would you like to connect to the website anyway?”

    Is there an solutions to disable this shitty Certificate-Popup's?
    I can set them to trusted but by doing this, more and more Ads pop up over time.

    Thanks for helping !

    -----FIXED IT-----

    LOCATION -> ROUTER-IP-> /opt/var/cache/pixelserv

    Last edited: Jul 15, 2017
  71. Almighty1

    Almighty1 Serious Server Member

    That all depends on where you are accessing the page from and should only apply when you are using a public computer. If someone was able to do that on your own computer, I would worry more about someone has already taking over your computer than that since all you have to do is set it so it goes back to the login screen to resume the session. There are reasons people want to disable the auto logout on the router so they can monitor things as they are happening.

    What you want is there under Adminstration -> System tab in the Web interface section under Auto Logout which is set in minutes or 0 for disable.
    Last edited: Jul 14, 2017
  72. rarepupper

    rarepupper Network Newbie Member

    Thanks! Didn't know where such a feature was but found it now!
    Although it can only let you set it to 10 mins and more...
    Tried putting a 1 but got an error, maybe it can be worked on for the next release to allow 1 minute auto-logouts.
    Almighty1 likes this.
  73. peyton

    peyton Network Guru Member

  74. XVortex

    XVortex Networkin' Nut Member

    XWRT-Vortex 380.67 is available and ready for download.
    There are bunch of improvements and fixes in there.
    Please see the changelog for info.
  75. Almighty1

    Almighty1 Serious Server Member

    Upgraded XWRT-Vortex successfully to v380.67 from v380.66_2
    XVortex likes this.
  76. Makaveli

    Makaveli Networkin' Nut Member

    Just updated as well everything is running good.
    Almighty1 and XVortex like this.
  77. GDT78

    GDT78 Reformed Router Member

    me too. All is fine.
    Almighty1 and Makaveli like this.
  78. Makaveli

    Makaveli Networkin' Nut Member

    I'm actually finding this firmware version has the most stable wireless connection for me, and memory usage also quite good.

    This may get my vote for best firmware yet.
    XVortex, Stimpy88 and Almighty1 like this.
  79. Almighty1

    Almighty1 Serious Server Member

    I wished I can tell one way or another since on my system, I am using the Tabs Outliner with Google Chrome and when I restore my 70+ tabs, Chrome will stop responding because the WiFi connection somehow is no longer transferring data so I have to disconnect and immediately connect back to the same WiFi before it will continue working again instantly. This is with a Intel 7260 Mini-PCIe WiFi card.

    Update - seems like it doesn't matter if I open tabs or not, sometimes a connection will just not have any data movement and I just need to disconnect and reconnect.
    Last edited: Jul 19, 2017
  80. peyton

    peyton Network Guru Member

    Flashed too, all fine ! :)
  81. Indyman

    Indyman Network Newbie Member

    Hello - first post. I want to telnet into my r7000 to add some cron jobs (I have the latest firmware version of X-WRT). I have telnet enabled in the firmware, but when I try to PuTTY in with the router's IP address (I changed it from the default) using my Username and Password (which I have also changed from default) I get an Access denied. So I enabled SSH (using default settings) and again am denied access. I can successfully login to the router via the Web GUI. What am I missing here? Is there a setting somewhere else that I need to change? Thanks
  82. Makaveli

    Makaveli Networkin' Nut Member

    I use putty and have no issues with SSH these are my settings in the router


    Scroll down to Miscellanous and make sure you have enabled Telnet.

    Last edited: Jul 21, 2017
  83. harrykh

    harrykh Network Guru Member

    Hi, someone changed the settings in the Wireless page(Pro tab) now I think its making my gaming worst. I really don't want to factory reset again, as I have set it meticulously. I just need to know the default values for the Wireless Professional tab for both 2.4ghz and 5ghz. And if someone has a better setup than default. Thanks
  84. Makaveli

    Makaveli Networkin' Nut Member

    These are the default settings.


  85. Indyman

    Indyman Network Newbie Member

    Hi Makaveli,
    Those are the same settings I am using as well. I do have Norton Security Suite and Windows Defender Security center but I still can't access via telnet or SSH with them turned off. I assume the r7000 firewall wouldnt prevent SSH or telnet on the private LAN? I'll keep looking - thanks for responding!

    UPDATE - SOLVED! My router password was too long - I had a 17-character password (I know I'm paranoid). When I changed it to an 11-character one I was able to telnet and SSH in. So I guess the limit for password length for telnet and SSH is somewhere between 12-17 characters!
    Last edited: Jul 21, 2017
    Makaveli likes this.
  86. Makaveli

    Makaveli Networkin' Nut Member

    phalkon30 and Stimpy88 like this.
  87. Indyman

    Indyman Network Newbie Member

    Ah OK - thanks Makaveli for your help!
  88. Frank2

    Frank2 Serious Server Member

  89. Frank2

    Frank2 Serious Server Member

    Mak, have you played around with DDNS or DNSCrypt/DNSSec or VPN?
  90. Leonardo MOrales

    Leonardo MOrales New Member Member

    Hello Guys!
    I'm using XWRT-VORTEX and is all I needed!

    Currently I was expecting an issue with FTP timestamps, those aren't shown properly and backup softwares detects that files aren't the same so re-copy all of them.

    Is anybody facing this? is there a workaround to solve it?

    Thank you!
  91. ideasky

    ideasky New Member Member

    How can I add the function of shadowsocks? Thanks.
  92. Makaveli

    Makaveli Networkin' Nut Member

    Hey Frank,

    I use No IP for DDNS it works don't really mess with it.

    DNSCrypt I don't use DNSSec I do use.

    For VPN I use a windows client the router would bottleneck my connection as I download over 300Mbps.
  93. rarepupper

    rarepupper Network Newbie Member

    Does anyone know why the 5Ghz band keeps disappearing/dropping?
  94. Makaveli

    Makaveli Networkin' Nut Member

    What country are you in and what channels are you using?
  95. khandu

    khandu Network Newbie Member

  96. Sleepy_Eyez

    Sleepy_Eyez New Member Member

    Hi all,

    Long time view of this forum, first time posting. I would like to share some back story before I ask questions. I first tired DD-WRT then Tomato and was a fan of the firmware because they were not stable. There was always something that went wrong with every update. I have been using Merlin for the last 6 months on my R7000 and it's awesome. I had to move the router location because it was sitting on top of my center channel speaker with 2 tower on either side and a microwave within 4 feet. I get much better WiFi now however I need help with QoS because my Fire TV was always connected Ethernet and I had no issues now I get a bit of buffering.

    1) Is there a guide to setup QoS on Merlin? I'm a noob when it comes to networking
    2) Can I safely increase TX power, if yes, what percentage?(under pro settings)
    3) I would love to run PIA VPN without a huge drop in speed. I normally get 150Mbps but with VPN on DD-WRT and Tomato I would get 25 to 40Mbps. I will have to use something like pfsense to get the performance I want.
  97. Indyman

    Indyman Network Newbie Member

    Hi Everyone,
    I'm trying to create a crontab in XVortex-Merlin (380.67) to wake up a server at a certain time. I have a script in /jffs/scripts called services-start to call the WOL file wol_nas.sh:

    #crontab for sending WOL packet to DADS_NAS at 10:55 pm every Sunday and 7:55pm
    cru a Sunday_NAS_on "55 22 * * 0 /jffs/scripts/wol_nas.sh"
    cru a Mon_NAS_on "55 19 1-7 * 1 /jffs/scripts/wol_nas.sh"
    logger DADS_NAS is awake

    The wol packet script wol_nas.sh is:

    sh /usr/sbin/ether-wake -b 00:19:D1:25:28:D3

    Problem is when I run the wol_nas.sh script I get the error /usr/sbin/ether-wake: line 1: syntax error: unexpected word (expecting ")"). I also dont see the cron jobs (cru l). I have jffs scripts enabled in firmware and both scripts have been made executable. The syntax of the ether-wake statement appears correct to me (apparently it is not) and the broadcast and MAC addresses are correct. What am I doing wrong?
  98. Makaveli

    Makaveli Networkin' Nut Member

  99. rarepupper

    rarepupper Network Newbie Member

    I live in the US. Using Auto Channels at the moment (132).
  100. rarepupper

    rarepupper Network Newbie Member

    I live in the US. Using Auto Channels at the moment (132).

Share This Page