1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Asus RT-N53 bricked.

Discussion in 'Frequently Asked Questions' started by Avantare, Jun 11, 2017.

  1. Avantare

    Avantare New Member Member

    Asus RT-N53 bricked.
    Firmware Version:

    Here's a YouTube video which has the step-by-step listed below it.
    Included here for convenience.

    Detailed procedure to install Tomato USB on ASUS RT-N53
    ***1.- Download most recent Tomato USB Firmware from: advancedtomato
    2.- Configure static IP on LAN connection, it can be any IP, just on 192.168.1.x range, i.e. and netmask
    3.- Power off or disconnect router
    4.- Press and keep pressed the reset button located at the back of the router.
    5.- Turn on or connect the router with the reset button still pressed. Wait about 30 seconds until power led blinks slowly as shown on video, this means the router is on recovery mode.
    6.- Connect LAN cable on computer, you may test connectivity by pinging on ip address.
    7.- Enter the router IP address on web browser to enter and see mini CFE web server.
    8.- Delete Router NVRAM (Not needed, but recommended)
    9.- Select Firmware file downloads on step 1.
    10.- Click the "Upload" button and wait for confirmation.
    11.- Wait a few minutes until the WiFi and network LED's turn on, just to make sure it finished installing the firmware.
    12.- Enter to the router configuration page,, user:admin and password:admin.
    13.- Enjoy!!

    I was able to access the router interface but only after it self refreshed.
    It initially gave an message saying something didn't happen. Unfortunately I did not make note of what that was.

    At this point my SO woke and was complaining she couldn't check her emails.
    Did a quick scan.
    All computers and phones show up.
    I pinged Google from my computer and got no reply.
    I restarted router and I'm using my E2500 for this post.

    *** I used tomato-K26-1.28.RT-N5x-MIPSR2-140-Max.zip located at tomato.groov.pl

    Here's the skinny...

    Followed #6 in the Peacock Thread FAQ at DD-WRT.

    Windows 7 x64 all up to date.
    Wired NIC driver up to date.
    Set static IP of

    Wireless NIC is disabled.

    Flashed to Asus RT-N53\tomato-K26-1.28.RT-N5x-MIPSR2-140-Max.trx
    I'm showing 'network cable unplugged.

    Pinging with 32 bytes of data:
    PING: transmit failed. General failure.
    PING: transmit failed. General failure.
    PING: transmit failed. General failure.
    PING: transmit failed. General failure.

    I have attempted the following with the NIC's configured as above.

    Power off computer and router.
    Waited a few minutes then powered on router.
    Only light on is power.
    Started computer.

    I'm still showing 'network cable unplugged'.

    Pinging with 32 bytes of data:
    PING: transmit failed. General failure.
    PING: transmit failed. General failure.
    PING: transmit failed. General failure.
    PING: transmit failed. General failure.

    Swapped out Asus with the E2500 it was going to replace.
    E2500 is running DD-WRT.
    I am unable to log into it as I do no remember the password and I cannot get it to reset so I can create a new password.
    I did not swap out the cable as I can successfully connect to the Internet.
    I can also connect wirelessly.
    All hardware is working.
    Issue HAS to be the Asus.

    I tried a 30/30/30 on the Asus. No luck.
    I tried to flash the Asus again. No luck.

    The only thing I can think is I did not wait long enough after the flash utility indicated it was done. I waited about 3-4 minutes.

    I also made sure to use the power supply that came with the Asus.
  2. Sean B.

    Sean B. LI Guru Member

    I didn't fully read your post as it bounces around quite a bit however:

    Use rescue mode to reflash the router. Keep in mind timing is hard/critical to get the upload to work. One trick that may help is to open a cmd prompt on the computer you're going to upload the firmware and run ping setting it to constantly ping the router IP.. then follow the procedure for starting rescue mode. As soon as the pings go from failed to a reply start the upload.
  3. Avantare

    Avantare New Member Member

    No matter what I do only the power light comes on and it stays solid. It never goes into recovery mode.
    I've used the command prompt to ping the router IP and get PING: transmit failed. General failure.
    This was in my original post, twice.
    I have scanned for SIDD's and it does not come up. inSIDDer just hangs at the screen 'Waiting for Wi-FI Data'.
    I have used my desktop, a laptop and my cell to search for the SIDD. It doesn't exist so it must not be broadcasting. Tomorrow I'm going to hard wire the laptop to the router but have no hope that I can connect and will get the same thing... 'network cable unplugged'.

    Perhaps reread the post?
  4. Sean B.

    Sean B. LI Guru Member

    Perhaps you should organize your post in a manor that is coehearnt to some sort of linear process. Apparently you're assuming I'm saying ping the router at any point in time looking for a response.. I'm not. Rescue mode uses TFTP and its server will be active for only a second or two upon a rescue mode boot attempt. And from a quick scan through the random points in your post I don't see you having tried clearing the nvram settings either ( this can be done via buttons, but I'm sure you know that ). Good luck.
  5. Avantare

    Avantare New Member Member

    I agree clearing the nvram settings will work/help. But don't I need to get to the router interface in order to do that or is there a way without opening it up? It is brand new and under warranty. Not sure about the warranty now though.

    Here's what I did earlier today.
    Hope it makes more sense!

    Before starting this process I ran the following 2 commands with a reboot after each one.
    netsh int ip reset
    netsh winsock reset

    Disabled wireless NIC.
    Disabled firewall, AV and malware.

    Assigned static IP.

    I successfully connected to the Internet using my other 3 routers.
    I did this to ensure the NIC and cable are good, overkill I know.

    I used TFTP and the Asus rescue utility for the process below.
    Started: ping -t
    Attached the RT-N53.

    Followed the instructions from the Asus site as well as other sites.

    I get a 'Network Cable Disconnected' on my desktop, Win7 x64 (as well as a laptop, Win10 x64) in Network Connections.

    When attempting to use the Rescue Utility and following the instructions in the Asus FAQ section (and from other places) the router never goes into rescue mode, the power light never flashes.

    Pinging the router shows.

    Reply from Destination host unreachable.
    Request timed out.

    Ping statistics for
    Packets: Sent = 167, Received = 142, Lost = 25 (14% loss),

    TFTP give this message after 5 attempts: Unable to get responses from the server.
    The Asus Firmware Restoration gives 'Invalid IP address.

    Am I missing anything?
    Any suggestions?
    I put in a ticket with Asus just before posting here.
  6. Sean B.

    Sean B. LI Guru Member

    With the router powered on, hold the WPS button for 30 seconds then release. I believe that should flush the nvram and reboot.
    Avantare and kille72 like this.

Share This Page